Questions & Answers

Faderport V2 (2018) and Reaper *SOLVED*

+1 vote
asked Jan 29, 2019 in FaderPort 2018 by devonkelley (250 points)
edited Jan 30, 2019 by devonkelley
Update - Check the Answers.

I know the Reaper community is pretty good at making things work that weren't necessarily compatible with Reaper but from everything that I read is that the newer faderport does not, CURRENTLY, have a 100% working build for it. Maybe I am wrong but the classic faderport has a working build that work completely with Reaper where the V2 doesnt.

Can anyone confirm this? Has anyone gotten the V2 to work with Reaper and is their anyway that Presonus would create a file that would help this process?


4 Answers

0 votes
answered Jan 30, 2019 by devonkelley (250 points)
selected Jan 31, 2019 by nickmaggio
Best answer

I figured it out. Kinda.

I was originall using a NanoKontrol 2 as a surface controller for Reaper so I had to install MCU Klinke V0.8 to get it to work. PS. it sucks. But while I was reading about .DLL files I found the faderport 2018 uses the the MCU .DLL terribly. Anyway I changed which DAW the Faderport is going to use (by holding the Next button while starting it up) to the Logic setup and HOLY ******* **** it worked. Everything works. Its a little spotty when it comes to the stop button, but other than that its perfectly fine.

TL:DR - Download the MCU Klinke V0.8 ( havent tried V0.8.3) and change the Faderports input to Logic (hold down Next on startup and press mute ( I think?) and under control surfaces go to Mackie Control Universal Klinke and set the MIDI in/out to Faderport and Boom.

Let me know if anyone else gets it working. 

0 votes
answered Jan 30, 2019 by franccriton (140 points)
Just received my Faderport V2 and unable to make it work with Reaper

Really need help before I send it back to the store
0 votes
answered Apr 1, 2020 by jan-paulhendriks (140 points)
Obtained the Faderport v2 from a friend. Initially it didn't work. After the firmware update to v3.42 and a restart of my Mac it does work fine with Reaper vs. 6.07 Catalina.
0 votes
answered Apr 24, 2020 by Rod Phillips (140 points)
Reaper Version 6.08 (Windows 64) and Presonus Universal Control (April 2020)(Windows 64) just works, mostly.

You need to have Universal Control open in the background (minimised).

Set your Faderport to MCU mode.

In Options/Preferences "Control/OSC/Web" set for Presonus Faderport FP2.

Highlight the Faderport device in the window and click the Edit button below. Select Midi In and Out as Faderport FP2.

This allowed the fader to control and update to the selected channel. Most of the buttons work by default but not the Next/Prev buttons or the scroll wheel which I'd hoped would allow track selection in the mixer window.

I'm investigating mapping those manually now and then possibly for editing plug-ins.