Questions & Answers

3rd party plug-ins faill to scan offline

+4 votes
372 views
asked May 22 in Studio One 4 by philipmikols (550 points)
Just upgraded to 4.5 and have to give it two BIG thumbs up! However one peculiar issue has come up. S1 will not scan any of my third party plug-ins when my computer is offline. When it is online everything scans just fine. This is not a huge issue because I can disconnect from the internet after I fire up S1. Is this a glitch or is this some anti-piracy thing or is there some new setting buried deep in S1 that I cannot find?

5 Answers

0 votes
answered May 22 by AlexTinsley (773,270 points) 1 flag
 
Best answer

If you have upgraded to Studio One 4.5 and your plug-in scanner is hanging when launching the program, it is because you are offline. One solution to this issue would be to go online with your computer. If this is not an option, here is what you can do...

  1. Go to Run in the Windows Start menu or open Cortana. Type in %appdata% and press enter. From the Roaming folder that appears, go into PreSonus/Studio One 4

  2. From the Studio One 4 folder, go into x64 and locate the Vstplugins.settings file. Right-click the file and choose to open it with Notepad.

  3. In the Vstplugins.settings file, locate the following line: <Attibutes scanAtStartup="1">  Change the 1 to a zero and save the file.

This workaround will prevent Studio One from scanning plug-ins on launch and should resolve your issue. Previously scanned plug-ins will still load. Another option is to install the 4.1.4 build of Studio One and go into Studio One>Options>Locations>VST Plug-ins. From here, you can un-check the "scan at startup" option. You can then install Studio one 4.5 after doing this, to get around the problem.

If you would like to roll back to a previous build, you can. Just log into your my.presonus.com and go to My Products>Software>Studio One 4. There is a link to view previous versions. You can download 4.1.4 from this list. Just uninstall version 4.5 and install version 4.1.4. Please check future release notes to see if the issue has been resolved.

0 votes
answered May 22 by andreylunev (180 points)
Из 4.1.4 копируете файл ucnet. dll и вставьте его в 4.5.0 с заменой. Program Files/PreSonus/Studio One 4
0 votes
answered May 30 by michaelhofsttter (270 points)
edited May 30 by michaelhofsttter
NO - this workaround does not work in any way. When beeing offline the scan still hangs up. If I abort the scan, no plugins/Instruments/effects other than Presonus ones appear in the DAW.

This is really annoying !!! I intented to use Studio ONE Artist offline in my basement where my studio is located.

Please fix this issue very soon! There is no need to go online at every single startup.

Jesus.....

kind regards

Michael
0 votes
answered May 30 by alehtrem (550 points)
Upgrade your studio to latest version 4.5.1.
This is already fixed and working properly.

Version 4.5.1 Release Notes (May 29, 2019):
The following issues have been fixed:
● Faulty assignment of ATOM pads
● Plug-in Scan freezes when Windows is offline
● Volume automation is laggy
● Crash on undoing instantiation of instruments
● Audio events disappear on bounce when writing tempo information option is disabled
● Crash on hitting Alt+Arrow up/down in empty song
● Limiter metering mode switch is broken
● Pop-up menu for "Add Insert" command has wrong properties
+2 votes
answered Jun 1 by dniitall (180 points)

it doesn't work for me. not even with the "great" fix in Version 4.5.1.

this problem begun in 4.xx and just refuses to go away. i have no choice but go bak to Ableton

...