Questions & Answers

AVB was working, moved to Mojave and it is gone, MBP late 2013 - SL24R

0 votes
59 views
asked Jul 21 in StudioLive Series III by chriscaouette (190 points)
I have experienced this on two Macs so far.   I have a late 2013 MBP with a Thunderbolt 2 to Ethernet adaptor.  Originally it was running Sierra and all was happy...AVB from my 24R to the Mac worked every time.  

Then I upgraded to Mojave and it shows on first install but once you restart all AVB connections are lost.

I am guessing this might be some sort of new permissions issue?  I cannot locate any answers out there other than other people asking the same question and not getting any answers.   

For full disclosure I am using the MOTU AVB switch but that should be perfectly fine.

2 Answers

0 votes
answered Jul 21 by chrissederqvist1 (1,790 points)
selected Jul 21 by chriscaouette
 
Best answer

My guess is that it depends on a kernel extension (kext) to be loaded at boot-time. Mojave has a strict policy for not loading untrusted or not properly signed kernel extensions (kexts), rendering lots of hardware DSP gear out in the cold.

You basically have two options if this is the case:

1. Go back to using macOS High Sierra (I have to do this on one of my machines)

2. Disable the SIP feature in macOS Mojave and enable loading of unsigned kexts as I'll describe how to do further down

If you want to do the second, be aware that it's not a recommended way of doing things according to Apple, but if you have to get it working, it is a temporary fix at least until (hopefully) the kext in question gets approved by all mighty Apple.

This is how to disable SIP and let "untrusted" kexts load during boot:

(You can turn SIP on again without problems if it does not resolve your problem, as described in the last section)

1. Shutdown your Mac

2. Whilst holding ⌘+R turn on your Mac, this boots into recovery mode

3. Select Terminal from the Utilities menu:

4. Enter the following command in the Terminal:

csrutil disable

5. Close Terminal by selecting Quit Terminal from the Terminal menu

6. From the Apple menu, select Restart

If you need to install any drivers or software, re-install it now with SIP disabled and reboot.

You should now be able to use your equipment if the Mojave SIP functionality was the culprit.

If this did not help, just repeat the process described, but when starting the Terminal in recovery mode type:

csrutil enable

And close the terminal and restart as described, and you're back where you came from.

Good Luck!

0 votes
answered Jul 21 by chriscaouette (190 points)

Thank you  chrissederqvist1 that was the solution!  I figured it was a permissions issue.  I have a backup boot of High Sierra if I ever need to go there now.

...