Questions & Answers

okay to update Mac OS on Studio One 2.6? I'm still on 10.7.5(2009 IMAC)

0 votes
451 views
asked Jan 21, 2016 in Studio One 3 by greghawks (120 points)
I'm still running the original os 10.7.5 on my 2009 IMac. It's the same os that I installed Studio One 2 on originally.  I use the Presonus Fire Studio Interface.

1 Answer

0 votes
answered Jan 21, 2016 by AlexTinsley (772,500 points)
Studio One v2.6.5 was the last release for Studio One 2 that runs on Mac OS X 10.8, 10.9, 10.10 and 10.11.

Now when you say FireStudio, you have to be careful because there are several products with that name and one of them does not work on 10.8 or higher, which is the FireStudio (2626) last supported OS was: 10.7.5 with Universal Control 1.2.

If you have one of the other FireStudio interface products, their compatibility is as follows.

FireStudio (Project or Mobile) as well as StudioLive Classic Mixers are supported on 10.11, 10.10 with UC 1.7.3

FireStudio (Lightpipe and Tube) which are no Legacy Devices are also supported on 10.11 and 10.10 with UC 1.7.3

Updates can be found on the download page: http://presonus.com/support/downloads
...