Questions & Answers

Studio One Artist - Midi is being 'sent' from my edrums, yet cannot be used with instruments

0 votes
42 views
asked Jan 31 in Studio One 3 by uthersayer (170 points)

So my old computer finally blew up, so i bought another. Loaded all my old programs onto it and everything seems to be fine. I have the extension to add 3rd party vst's onto Artist and have Ezdrummer 2 in the daw. I can record normal audio through my itwo nicely but i cannot use the midi within Studio one. I have "added a device" and so on however the Midi reads on the 'sent' option on the midi monitor but it does not read on the 'received' segment. Very confusing. I can also use Ezdrummer 2 on the standalone version which makes me think it must be studio one or a weird driver issue. Also, the box where the device would usually go within the plugin screen, it will not let me touch it and the only response i get is if i hover over it, it will say 'focus device'. No matter how hard i click it it does nothing which is beyond frustrating. i feel this new 'universal control' might be inferior to the previous audio box driver (which if any one has access to please let me know)

2 Answers

+1 vote
answered Jan 31 by jaydoudican (160 points)
Try adding your midi drums as a keyboard.  I had the same issue and that fixed it.

Good luck.
0 votes
answered Jan 31 by uthersayer (170 points)
Changing to a Keyboard worked perfectly. Can't believe i did not try that in the first place. Thank you so much
...