Questions & Answers

Studiolive 24.4.2 connection problem

0 votes
78 views
asked Feb 4 in Classic Mixers by damirnezirovic (150 points)
Hello, got a big problem.I have a studiolive 24.4.2 mixer (firmware:1.0 Bulit 195) and i cannot conect it. It says that on my firmware and bulit i must instal Universal control 1.7.3, which does not exist any more. Where can i find UC 1.7.3, or can i change my firmware or bulit in order to install diferent Universal Control version! Connection is a firewire....have also 16.0.4 and it work with coresponding Universal control just fine. Thank you for your reply :)

1 Answer

0 votes
answered Feb 4 by wahlerstudios (104,000 points)
selected Feb 6 by jonnydoyle
 
Best answer

You can find all versions of Universal Control on the download page of your mixer. Firmware versions are available in your Presonus account for registered products (my.presonus.com). See "Select your operating system" and "Show/hide all versions of software downloads..." You should be able to use Universal Control v.1.7.6 for both mixers (with matching firmware versions).

https://www.presonus.com/produkte/de/StudioLive-24.4.2/downloads

...