Questions & Answers

I need to unplug, and replug my PreSonus AudioBoxiTwo for windows to detect my microphone

+1 vote
318 views
asked May 14, 2020 in AudioBox i-Series by brandonj1 (170 points)
Hello.

I have been using an Audio Technica AT2025 attached to a PreSonus AudioBox iTwo for several years now. I have recently (last 12 months) been running into an issue where my microphone will not pick up audio unless I unplug and replug the USB-B cable into the box. It will show up in the Windows sound manager as my default device, but will not show any audio going into it. No software (such as OBS or Audactiy) will not pick up the audio either.

I am fairly techincal and have tried all sorts of troubleshooting but it does not seem to work. I am currently using the Universal Control for software to make the box work (provided from the PreSonus website)

I just reset my PC to see if that would fix the issue, but it has not. I have also looked on the website for an answer but have not found one.

Any help would be appreciated! Thank you!

For technical specs (though I am not sure any of it matters);

OS: Windows 10

CPU: Ryzen 1700 (OC 4.0ghz)

MOBO: X370 GAMING PRO CARBON (MS-7A32)

RAM: 128GB (4x32) DDR4 3200MHZ

4 Answers

0 votes
answered May 16, 2020 by joerancourt (200 points)
Much less beefy pc, MS surface, windows 10,  4 gb ram, brand new audio box usb 96 audio interface, (that Always needs restart - has never worked from studio one quick start successfully even once,) brand new condenser microphones ive never heard yet.

Is there another software i can test with to determine if ita audiobox interface or studio one software???
0 votes
answered Jun 19, 2020 by brandonj1 (170 points)
Bumping this thread to see if anyone has an answer...
0 votes
answered Jul 26, 2020 by juanpabloolivera (200 points)
Hi, i solved it installing old drivers. They're on the official site, check if that helps.
0 votes
answered Nov 24, 2020 by daniachim (140 points)
edited Nov 25, 2020 by daniachim

Works with Universal Control v2.6.
Does not work with latest Universal Control v3.4.0.61835


This has been going on for at least a year and is almost certainly driver related, please look into it.

Edit: I was wrong, proves problematic after restart. Going to try another USB port or enable EuP/ErP Ready in bios.

Later Edit: Solved in my case by plugging into another USB port.

...