Questions & Answers

External device TB-3 not showing or playing / sync in Studio One 4

0 votes
58 views
asked Jun 25 in Studio One 4 by davemooney1 (220 points)

Heyoh!!

Just got a Roland TB-3 and have followed the setup for the external midi instrument in studio one 4 to the letter, as i have done many times before without issue. Firstly with the usb cable it doesn't even show when plugged in via usb, I have the driver for the TB-3 downloaded and installed (mac OS 10.13), i've changed the usb cable and port twice, i've even tried with standard midi cables (I used an i-connectivity mio 10 which has no issues running other equipment) and still it doesn't play back / sync. I have also set the TB-3 to receive midi from an external source on 1 and all channels! No joy!  

I'm defo missing something! Is this a TB-3 issue? angry

Running iMac 10.13, 32gb, 4.2ghz cpu, antelope orion Studio 2017, 

 

4 Answers

0 votes
answered Jun 25 by aka_busker (21,130 points)
Hi, how have you installed the device in studio one - instrument or keyboard?  I had issues with a dual mesh drum kit (Roland TD1 Drum module) when I connected as an instrument it wouldn't work controlling Ezdrummer.  As a keyboard it worked a charm.  Looking at that device I would imagine it needs adding as a keyboard not as an instrument or controller.  
0 votes
answered Jun 26 by davemooney1 (220 points)

Hey Busker thanks for the reply yes. I have tried that also with no joy, which is why its a bit of a head scratcher. The unit itself doesn't show on the list of connected external devices and even with the midi io it doesnt playback. I'm going to have another crack at it in an hour or two and I'll keep you posted.

Cheers Busker.

+1 vote
answered Jun 26 by davemooney1 (220 points)

Okay! Went back through the readme doc (which I never read, ever!) in the driver download folder for the TB-3 and there it is! Instead of being plug and play like nearly every other device out there its plug, 10 steps later and play! Theres a whole routing procedure to do in the utilities midi setup on OS 10.13! 

I'm not as big a nerd as I though I was! As the old saying goes, when i doubt Read The F*$&ing Manual! blush

0 votes
answered Jun 26 by aka_busker (21,130 points)
Hey man, happy to help if I can.  Roland and midi can be funny.  Boss is the same if you use that gear.  Like, I have midi in and out on a loop station but it only connects to other loop stations and controls both together.  Strange how they helped create the spec but do weird stuff with it.  Their gear can make you feel like that sometimes.  Yeah, I avoid telling people to RTFM.  I work from the assumption you have!  (Even if I don't half the time!).  
...