Questions & Answers

Rewire system library is too old

+1 vote
1,984 views
asked Jul 8 in Studio One 5 by busterny (510 points)
edited Jul 8 by busterny

Upon startup in Studio One 5, the message "The ReWire system library is too old (at least 1.8.7 required)." appears. Is this a bug, am I missing some ReWire functionality, or other? 

ReWire error message

I am using a 2019 iMac, macOS Catalina v10.15.5, 3.6 GHz 8-Core Intel Core i9, 72 GB memory, multiple SSD drives. This message began only post-upgrade to S1 v5.

Anyone else seeing this behavior?

Cheers. ;-}

10 Answers

0 votes
answered Jul 8 by busterny (510 points)

As a matter of community interest, solved the issue by going to this article:

https://support.presonus.com/hc/en-us/articles/360045479912-Studio-One-5-ReWire-Error-Message-Upon-Opening-Studio-One-5

Apparently installing the free Notion demo takes care of the ReWire issue; not sure I understand the logic of having to install another product to address this, but that's the recommended fix.

0 votes
answered Jul 8 by purpose (260 points)
The information in the link did not work for me, can I just delete this program since V5 wont use it?

If so how do I do that on a Macbook Pro

Mike
+2 votes
answered Jul 8 by busterny (510 points)
Apparently, the functionality of the Notion Demo link is non-responsive at the moment. Not sure if it’s server overload due to high volume or other; been trying to access it since yesterday with no luck. I put in a ticket to be sure it’s addressed.
+2 votes
answered Jul 8 by TomTama (1,090 points)
Just ignore the message unless you're using Rewire. It doesn't prevent S1 5 from functioning.
+6 votes
answered Jul 8 by busterny (510 points)

OK, finally solved it completely. After downloading and installing Notion, as per the support article, I still had the ReWire error message in S1v5. What the support article failed to mention, is that you must set the Enable ReWire checkbox within the Notion Preferences dialog box before ReWire functionality is enabled. Otherwise, no dice, as Enable ReWire is off by default.

Enable ReWire checkbox

Once Notion is restarted, post-ReWire checkbox being enabled, you'll no longer see the ReWire error message within S1v5 on startup.

HTH,
;-}

0 votes
answered Jul 10 by maronsandvik (180 points)
Link on Notion 6 is not working. when I click, get demo on my presonus account , it says Loading.. for one second, than it goes back to get demo. anyone else having the same problem?
0 votes
answered Jul 12 by oscarrodriguezgarcia (180 points)
I have the same problem, I need a link to the Notion 6 demo, I only find the purchase option on the Prosonus website.Yo tengo el mismo problema, necesito enlace a la demo de Notion 6, solo encuentro la opcion de compra en la web de Prosonus.
0 votes
answered Jul 12 by oscarrodriguezgarcia (180 points)
I have the same problem, I need a link to the Notion 6 demo, I only find the purchase option on the Prosonus website.
0 votes
answered Jul 24 by m@P (1,680 points)
Great sleuthing there Busterny!  thanks for the screen shot!!

As I already had Notion I was a bit perplex'd at redownloading until I scrolled to your post!

thanks again!!
0 votes
answered Jul 28 by coreywilliams7 (150 points)

I also had the same issue of Rewire not starting up correctly when opening studio one 5. I was using Rewire just fine with my outboard gear for about a week or so, and then all of a sudden it began acting weird not functioning properly- and then ultimately giving the error on start up " "The ReWire system library is too old (at least 1.8.7 required)." I did not have the included ( with my sphere) Notion software installed, as I don't use it too much... After installing the software, opening up the Notion preferences, and selecting " enable rewire" ,as shown this feed by another user, then restarting, etc, and re opening back up studio one 5 with no problem! 

...