Questions & Answers

Midi assignments to controller not remembered when starting a new song

+3 votes
asked Jul 9, 2020 in Studio One 5 by federicosilva (4,460 points)
If I create a couple of assignments to my midi controller, like mapping a button for next channel, when I start a new song those assignments are gone. Don't know if this is a bug or a missing feature. Either way it makes the assignments kind of useless if you have to set up every button each time you start a new song.

5 Answers

0 votes
answered Jul 10, 2020 by stanthompson2 (5,890 points)
If saving the song or saving as a template (even if you do not use the template) does not save your assignments, you may have to create a generic MIDI keyboard under options in S! and a generic (or blank) preset on your MIDI keyboard controller then map every knob, fader and button manually. Remember there are global and instrument maps and some assignments that are in the global maps are also in the instrument maps. It's time consuming but if it fixes your issue... StanT
0 votes
answered Jul 10, 2020 by federicosilva (4,460 points)

I'll give you more information, I think I got the case when this happens. The midi device I have mapped is a Launchpad X, I did all the steps to configure it, creating a new midi keyboard and learning every button. If I start a new song and add, for example a couple of assignments like this:

You can see I have two buttons assigned to actions. 

If I close S1 and start a new song it's ok, my mappings are still there, but if I open an old song that doesn't have this mappings, it gets overwritten somehow. After that if I close and open S1 again and start a new song I get this:

I hope that clarifies the issue a bit more. 

This sounds like a bug to me because opening a song should't overwrite the mappings of a template or of a new song. 


0 votes
answered Jul 11, 2020 by stanthompson2 (5,890 points)
I forgot to mention; if your Launchpad X device has a way to save a built in or generic S1 preset after you assign the buttons (like I can on my Akai MPK261) and you assign those buttons in focus:instruments maps instead of global maps and it still does not work, then you are right, its probably a bug
0 votes
answered Jul 13, 2020 by federicosilva (4,460 points)
I'm not sure what you mean by saving saving a generic preset on the launchpad, I'm using a custom mode I created for it, so I'm sure the values I'm sending to SO are always the same. What gets lost when I change songs is the actual assignment inside SO. Haven't played enough with the focus mode to be sure is working properly.
0 votes
answered Apr 26, 2022 by basemalattar (1,470 points)
edited Apr 26, 2022 by basemalattar
I had a very similar problem. I could always assign midi Control easily through my ********* BCR2000 hardware controller to any plugin on S1 4.x.  But when I upgraded   to an M1 Mac and updating to S1 5.x, suddenly  if I quit Studio one and restarted, all control assignments where forgotten. I could easily reassign them and they worked through the session but quiting and restarting s1 wiped all assignments out once again.

  I assumed this was due to moving to an M1 machine, since everything worked flawlessly on my previous intel machine. I went nuts trying to identify the cause and solve the problem.

Finally, I deleted all my midi device settings from Studio One, reconnected and (very important) renamed them all to a different name. I then went through the process of relearning all their pots and buttons again. This worked and assignments are now recalled. Obviously this was a long and tedious process but it was the only thing that worked.

Hope this helps, good luck.