Questions & Answers

The Learn Videos are not playing on my Windows computer

0 votes
36 views
asked Jul 9 in PreSonus Sphere by davidevans15 (400 points)
I just upgraded to PreSonus Sphere, I am on a Windows 10 computer. When I go up to Sphere and select Learn, none of the videos are playing. They just sit there, doing nothing.  I can play videos on other platforms such as YouTube and Teams. I even create Videos.    What am I missing???

1 Answer

0 votes
answered Jul 13 by AlexTinsley (902,800 points)
 
Best answer

The exclusive content platform is using Vimeo which has their own requirements for video streaming and playback

Desktop OS and Browser

In addition, we recommend using the following browsers and versions on Windows 7 or later or macOS Sierra (10.12.6) or later:

  • Chrome 30+ (has automatic updates)
  • Firefox 27+ (has automatic updates)*
  • Microsoft Edge
  • Safari 9+ 

*H.264 video (required for viewing Vimeo videos) is only supported in Firefox for Windows 7 and later. Firefox versions on Windows XP are no longer supported for playback. 

Firewalls and whitelisted domains

Viewers should ensure the following ports are open on their network for playback:

  • TCP/UDP 80 (HTTP)
  • TCP/UDP 443 (HTTPS)

In addition, if your viewers are on a corporate network (office, university, hotel, etc.) that restricts access to certain websites or domains, they should have the following domains whitelisted:

  • *.vimeo.com
  • *.vimeocdn.com
  • *.magisto.com
  • *.akamaized.net
  • *.cloudfront.net 

...