Questions & Answers

Why are midi notes playing but not being recorded?

0 votes
2,091 views
asked Dec 9, 2016 in Studio One 3 by tiosongs (150 points)
I am using a KORG Triton as a midi keyboard controller (as I always have) but it no longer will record midi notes. When I try to record a track using a virtual instrument it plays back while I'm recording and I can see certain data being recorded (velocity, pitch bend, etc...) but no notes. The controller plays the virtual instruments perfectly but it will not record midi note data. I have tried removing the device and adding it again, rebooting the program and the system, tinkering with midi settings and everything I can imagine but I can't make any sense of it. Please tell me there is a simple solution that I am overlooking.

HELP !?!?!???

Dell XPS laptop

WINDOWS 10 64-bit Home Edition (with latest updates), 16GB RAM, x64-based processor

Studio One Professional 3.3.2.40899

Presonus AudioBox (driver version 2.21.0.5653

KORG TRITON 61 key

8 Answers

0 votes
answered Apr 12, 2017 by PreSonuSupt4 (219,630 points)
 
Best answer
If you can record everything - but - midi notes, that suggests some kind of filtering or some other larger issue.  When you run into midi issues like that, open View > Midi Monitor and view the incoming data in real time and also look at the arrange instrument track in record and monitor to see if it's metering when you play notes.   If it is doing both things, the data should be recorded.

We assume that there's not a NoteFX Input Filter plugin on the track or something similar that's filtering out note ranges.

Look carefully at the note messages in the Midi Monitor to see what they are, to make sure something strange is not going on like the notes being transposed out of range of the instrument.  If you continue to experience this issue, make a support ticket so that a support rep can look closer at it and try to find a solution.
0 votes
answered Jan 13, 2018 by alvarodorantes (140 points)
I have the same problem were you able to fix it? Thanks! !
0 votes
answered Jul 3, 2018 by lavoll (170 points)
check if "auto punch" is enabled. Shortcut " i "
0 votes
answered Dec 20, 2018 by cedricisrael1 (340 points)
I ran into the same issue and I think I fixed it.  First click into your midi instrument so all the settings at the top appear.  For example I am running contact player, so make sure you can see the full window page in S1. Then make sure that in that window showing the instrument, in the top right hand corner that your midi device is listed, and very importantly it should be highlighted yellow.  Once I made sure that my controller was highlighted, that seemed to fix the problem and midi notes were tracked.
+1 vote
answered Jan 7 by craigtoomey (290 points)
I had the same issue.  Midi won't record outside of where you set loop markers and you have them active.  Once I unactivated the loop markers, I was able to record the midi again.  Hope this helps.
0 votes
answered Feb 14 by jbair (340 points)
Yes I’m having this same problem and I’ve checked everything. The only thing I have done is replaced my studio box usb with a 1824 interface (presonus) and now I can hear my notes being played back etc when I have instrument in track. When I record nothing. only thing that gets recorded tho is pitch bend etc. just no notes. Did you figure this out?
0 votes
answered Feb 14 by jbair (340 points)
Well I just figured it out. I had to remove the triton external device set up that I already had made. Basically delete it and create a new one. Hit the add button, new keyboard etc etc. And bam then I could record my midi notes again. Very odd. But now it works just fine hope that helps anyone having the same problem. Just needed to be re configured again.
+3 votes
answered Feb 25 by davidricher (200 points)

I had the same issue but, finally got it to work by doing the following...

  • Click on the Inspector or "i" icon a the top left area (where your Marker Track Icon etc is) shortcut (F4)
  • Look about half way down and you'll see the name of the instrument (in my case "Mai Tai") that you are using with the following below it:
  1. Out: Instrument Name (in my case Mai Tai)
  2. In: THIS WAS THE PROBLEM. Mine was set to the wrong Midi Device. I am using an AKAI MPK249 and this was set to my V-drums.
  3. Channel: Instrument Name (in my case Mai Tai)
...