Questions & Answers

Studio One 5 - always ask eula on startup and does not save preferences (solved with uninstall/reinstall)

+2 votes
asked Jul 13, 2020 in Studio One 5 by jcpzero (140 points)
edited Jul 16, 2020 by jcpzero

Presonus Support responded to my help ticket.  Was able to solve by removing/unistalling on my iMac and then downloading/reinstalling Studio One 5.

Thank you to those that responded - it was nice to know I was not alone.


Cubase user trying out Studio One 5 via sphere.  I have studio 5 installed and activated.

On startup, studio one asks for EULA every time and does not save preferences.  Have to re-choose playback device, won't remember that I unchecked scan at start up for VST plug-ins, won't remember to create new song when studio one starts or anything I change from default in preferences.

Seems like the program thinks it is the first time running every time.

IMac, Mojave OS  (Updated to latests Catilina OS and that did not solve)

5 Answers

0 votes
answered Jul 15, 2020 by Magic Mendez (170 points)

I am having the same issue.., and it's ANNOYING AF!!! WTFF???!

0 votes
answered Jul 15, 2020 by georgeheredia (240 points)
I have same problem, coming from Studio One 4.6 Pro which still loads very fast.  

In addition, the loading is excruciating slow - about 10 times or more slower.  In fact, I usually just walk away and make pizza or coffee, and come back later.

Also, some plugin software is not loading properly.
0 votes
answered Jul 23, 2020 by themontae (140 points)
I had the same problem. Tried the uninstall and re install with no success. It ended up being the permission on the Presonus folder in library/application support/presonus has to be set to "read/write"
0 votes
answered Nov 25, 2020 by pascalglanville (140 points)

I'm having the same problem on my Mac Book Pro running Catalina. 

I've unistalling and reinstalling Studio One 5 to no avail.

And checked read and write permission on Application support. 

But to no avail. 

Managed to get it working on my Mac Pro also running Catalina without a problem. 

Very frustrating. 

0 votes
answered May 19 by dlindsaymouatt (390 points)
This is continuing to happen to me on windows 10. Last time it was right before a performance and I had to stand there for 20 minutes remapping every VST preset in a song because it Also forgets everything.

Reinstalling does not fix the issue. It happens at random. Presonus needs to correct this. On S15 5.4.