Questions & Answers

I have a solution to slow save problem

0 votes
60 views
asked Jul 15 in Studio One 5 by arthurzatarain (1,160 points)
For 7 months I’ve been fighting (with polite assistance from Presonus) an awful problem with Studio One requiring 2 to 6 minutes to save a song. S1 would work fine for a while, maybe an hour, and then go into slow save mode. S1 was totally non responsive during the save, I couldn’t even stop the transport. CPU load was normal, memory was plenty, zero disk activity until the last moment of the save. The save dialog box ticked away slowly with seemingly endless messages about Packaging and Saving every aspect of every track, plugin, etc. The slow save problem started with S1 4.5, got worse with 4.6, and in version 5 was almost constant. My songs are small, typically 1Gb, with less than 30 tracks  

The constant problem in version 5 provided opportunity to find a fix and, based on a long day if song editing, I think I figured it out.  On my Dell Precision 7510 32Gb notebook with Win 10, the problem seems related to the high performance graphics processor. I didn’t believe it either! But the evidence is clear: the high performance GPU is a problem for S1.

At first I disabled the AMD FirePro display adapter in device manger. Problem went away!  I re-enabled the display adapter but configured Windows to assign S1 to only use the low power, integrated display adapter (Intel in my computer). Problem didn’t return. I then set windows to let S1 use the AMD FirePro high performance GPU display adapter and the problem returned in 10 minutes. I set S1 back to use only the Intel adapter and the problem went away.

I also noticed that the computer fan doesn’t run nearly as fast (and loud) as before.  The CPU load isn’t any different, so the fan must have been the one on the GPU. My computer fan noise is barely noticeable now.  

Maybe I lucked out and fooled myself, but I think S1 has a problem (at least for me) when the high performance GPU is used. If you have odd problems of any type try disabling the secondary GPU. It seems to have worked for me.

Please log in or register to answer this question.

...