Questions & Answers

HELP!!! Need help installing 3rd party vst2/vst3/etc on Studio One Artist 5

0 votes
73 views
asked Jul 27 in Studio One 5 by michaellavender (280 points)
Hello! so i am completely new to the studio one world! i came from Reaper where it was SUPER easy to install Vst2/vst3 programs into my DAW. been using studio one for a week now and was frustrated by how difficult it is to get these 3rd party vst's to pop up. a couple days ago i was able to somehow get half of the vst's i have to show up in my program. it was by luck.. i have no idea or recollection as to how i did it lol. im trying to make it easy to install the others/ any new vst's that id download in the future! i know its possible on the version i have. but how??? help this noob out pls. Thank You!

6 Answers

+1 vote
answered Jul 27 by cdricblanqui (5,340 points)
Hi,

Did you, in the setting options, add the location paths where the VST's (*.dll or *.vst3) are installed ?

(And remember that SO1 do not accept 32 bits VST"s anymore, so you won't see them)

HD
0 votes
answered Jul 27 by michaellavender (280 points)

@cdricblanqui i have no idea what you’re talking about/what that is, can you explain it further in a step by step so I can try it first thing in the morning? It all seems scattered and such Thank you! This is all new to me.

0 votes
answered Jul 27 by cdricblanqui (5,340 points)
Start SO1, In the main menu choose "Studio one"  then "Options"

In the new window, select the "Locations" view, that's where you'll tell SO1 where to find the VST"s.

Default location for VST2 executable (dll)  is C:\Program files\Vstplugins (or in the directory you specified when you installed the product)

Default location for VST3 executable (vst3) is usually C:\Program files\Common files\VST3 (or > same as above)

Add as much locations you need and check the "Scan at startup" box so SO1 will take those in considerations for next start.

Hope that helps.

And you should check the user manual too for complete info ...

HD
0 votes
answered Jul 27 by fschmidt (4,660 points)

Had this problem too when I first started using Studio One
until I noticed that for some strange reason
S1 needs to be able to access the internet when starting the program!

If your firewall blocks S1 to reach for the internet it will blackmail all third party VSTs...
Mabye this helps...

0 votes
answered Jul 28 by michaellavender (280 points)

@fschmidt how do i take that off? @cdricblanqui i did exactly that and still nothing. This is frustrating lol. heres an image to show what ive done. 

0 votes
answered Jul 29 by fschmidt (4,660 points)
Try to bypass/disable your firewall (should you have one) when starting S1.
...