Questions & Answers

Fader jump after release?

0 votes
asked Jan 5, 2021 in FaderPort 8 by ricklang (190 points)
edited Jan 5, 2021 by ricklang


Recently ordered a brand new Faderport 8 v2 and quite happy with it. Read the manual a few times. Updated to latest firmware 3.44. Obviously understand I cannot map everything for other DAWs, but to a reasonable amount at least. The main issue (which seemingly is what other Presonus users also have noticed overall) is the fader calibration, or the lack thereof. Moving a fader on the Faderport, it also moves the respective channel fader in my DAW, but upon releasing the physical fader it twitches and changes it's position up or down to match the resolution on the virtual fader. So technically they are both "correct", but the problem is obviously that the resolutions don't match on the FP vs DAW fader.  The itch is merely the small adjustment the fader has to do when letting go of the fader, i.e. hopping up to the correct corresponding number on the FP scale to be aligned with what the DAW's fader is reporting.


Basically: If I am at, for example, 0 dB, both in DAW ITB and the FP fader, and then turn the FP fader slowly down until I reach, say, -20 dB in DAW – the physical fader on FP is maybe now closer to -30 dB. When letting go, it jiggles its way up to -20 dB to match DAW fader. And so on.

Anyone else experiencing/experienced this fader twitching? To be expected when using FP8 under the normal MCU protocol?Thought of using this unit during mixing of our next release, but when Japan calls I'm not sure I can recommend it quite yet.

Update: Here's a video explaining what I mean - > 

1 Answer

0 votes
answered Jan 5, 2021 by ricklang (190 points)
selected Jan 5, 2021 by ricklang
Best answer
I believe I have solved it. I did a new factory reset to firmware 3.21 from June 2019 and tried. Seemingly no twitching. I then uninstalled everything. Including Universal Control software (which really wasn't necessary). Went through the process anew and updated to firmware 3.44. Calibrated, rebooted etc. and so on. Tried in Cakewalk/SONAR and Reaper. The twitching was back. Did a new factory reset to 3.21. Recalibrated. Rebooted. Twitching gone. So the solution is to NOT update to firmware v. 3.44, and if you have: do a factory reset.

So to elaborate: this firmware most likely addresses the "need" to have virtual faders match the fader resolution on the Faderport. The thing is that Cakewalk/SONAR does not have the same fader resolution (nor can you change it). That one is from infinity to +6dB, while FP is from infinity to +10 dB. So if you are somewhere in the middle with the faders running the newest firmware, you might be ok. But way down below -25 or so on the FP the virtual fader hasn't reached that far due to resolution – which is why it jumps back up. Same thing if you go above 0 dB.

So basically you will use 3.44 and see that FP faders match the virtual faders, but accept twitching. Or revert back to old firmware, get rid of twitching, but then realize that the difference in fader resolution means that -20 in your DAW might be -24 on your FP fader. And so on.

Thanks all for input!