Questions & Answers

Powered USB Hub with Studiolive; and Studiolive 32SC not connecting as Audio Interface to Studio One

+1 vote
785 views
asked Jan 13, 2021 in StudioLive Series III by lancebrown-ochs (630 points)
I'm getting a "Power Surge on USB Port" error when connecting my new Studiolive 32SC to my PC.  I did all the troubleshooting suggested by Dell, and the final option is to use a powered USB port.  Any idea if that would work?  I've reinstalled Universal Control (and drivers) about a dozen times, but the issue remains. Also, I can see the Studiolive Series III as an interface in Studio One 5, but get the error that says "The audio device Studiolive Series III could not be initiated...".  I'm stumped!  FYI, this is a relatively new powerhouse of a PC and it works perfectly with my Studio 192 interface.  I've got the Studiolive connected via USB and the Network cable (direct connection...not wireless).  Any ideas out there?

2 Answers

0 votes
answered Aug 27, 2022 by weswild (260 points)
Its defo a problem with the usb . does it work for a while and then kick you off the network ? Having a similar problem . tried every setting in windows 11 but the tower has an inhumane amount of usb ports , some of them must be on a hub as i couldnt see a board having that many sockets for usb . .  please let me know if you got this fixed or are still chipping away .
0 votes
answered Mar 15, 2023 by billlong (340 points)
I have a similar problem. I have "solved" this issue by unplugging the USB connector on the back of my StudioLive 32SC mixer and plugging it back in. I attempted earlier to resolve this problem by having my USB connections for my Windows PC to never expire or to Sleep. This did not work.
...