Questions & Answers

Does any have MacOS issues deleting audio files when "Remove Unused Files/Delete" on a SMB/CIFS Share: Unknown Error

+2 votes
217 views
asked Apr 16, 2021 in Studio One 5 by matthewburbridge (240 points)

I am trying to set up a SMB/CIFS share to keep my songs on.  Loading, recording etc all work just fine but when I try and remove unused files (delete files permanently) I get the following error

Some files could not be deleted.

Unknown Error (/Volumes/MJB/test6/Media/Track 1.wav)

I have tried on three different NAS servers: Windows 10, Centos7 and Netgear ReadyDuo and all give the same error.

It is not a permissions issue because when I close the song I see Studio One successfully deleting another file (see below) in the Media folder which was created at the same time and has the same permissions.  I can see it being deleted when running studio5 through dtruss:

unlink("/Volumes/MJB/test6/Media/Track 1(2).wav\0", 0x0, 0x0) = 0 0

I can delete the file from the Finder app with no problems

How anyone else seen this issue:

Would be good if someone else could try it and post the results

Many thanks

Please log in or register to answer this question.

...