Questions & Answers

How do I connect an SL16.4.2 classic mixer to my new Dell with USBC Thunderbolt?

0 votes
asked May 4, 2021 in Classic Mixers by COEA (160 points)
I may be SOL, but here I go. I want to connect an old SL 16.4.2 Classic mixer to my new(ish) Dell Laptop. It is equipped with a Thunderbolt 3 (?) USBC port. I purchased and a completely unreasonable price the appropriate Apple adapters to get me down to the firewire 1394 cable. As seen on a youtube video, This is supposed to allow firewire devices to be connected to your laptop. I have made the connections, installed Universal Control 1.7.6 and my Mixer is v. 1.50b build 190. But the mixer does not show up in UC. It's possible I may need to uninstall and go through the painstaking process of cleaning all the files out and reinstalling. I guess I will give that a try while I await your suggestions. My fear is that it simply will not work. The odd thing is that even though it doesn't show up in UC, I can see an option for presonus Firestudio  in my capture software. But it will not connect. If I delete UC, that option is gone and the only option available is the windows audio. So, something is getting through. I also tried setting the Firewire link ID to zero. Something I found on a similar post. That didn't work.

Any ideas?

1 Answer

0 votes
answered May 7, 2021 by COEA (160 points)
I figured it out! I think I mentioned that the device manager saw the studio live, but it indicated that there were problems with installing it. So I did some research on on the error message it received. There was the standard "Look for new drivers" suggestions, but the one I tried and believed saved the day was installing the Universal Control app in compatibility mode set to windows 7. I also found a folder that had a license in it that I deleted as well. Not sure if I did that before trying this or not. The other thing to watch out for is to make sure you "allow" the apple thunderbolt adapters access. I noticed the icon in the hidden icons menu and clicked on it. I needed to grant access. Not sure what role that played, but that alone didn't solve it. So, in short.

1. Make sure you uninstall anything that might conflict with UC. 2. Make sure the adapters have the proper permissions. 3. Try installing and running UC in windows seven compatibility mode. A quick google search will show you how to do that.

It's nice to be able to use my mixer in this way again! Was stuck using old PC's with a firewire card.