Questions & Answers

It's impossible to disable snap in arrangement view from editor using macros

0 votes
243 views
asked Apr 26, 2023 in Studio One 6 by brhubbard (120 points)

Hi. I have a macro for duplicating notes from the midi editor in arrangement with 'Duplicate and insert' command.

Sometimes it duplicates events with silence, thanks to the snapping. Unfortunately, it's impossible to disable snap in arrangement from editor using macro:

<?xml version="1.0" encoding="UTF-8"?>
<Macro title="Disable Snap" group="" description="">
    <CommandElement category="View" name="Editor">
        <CommandArgument name="State" value="0"/>
    </CommandElement>
    <CommandElement category="Edit" name="Toggle Snap">
        <CommandArgument name="State" value="0"/>
    </CommandElement>
</Macro>

It works perfectly if i close editor by hands, and then call this macros:

<?xml version="1.0" encoding="UTF-8"?>
<Macro title="Disable Snap" group="" description="">
    <CommandElement category="Edit" name="Toggle Snap">
        <CommandArgument name="State" value="0"/>
    </CommandElement>
</Macro>

Maybe there are other ways to do this?

Please log in or register to answer this question.

...