Questions & Answers

Error message while trying to install Faderport (Windows 10): Could not find Control Surface.

+4 votes
994 views
asked Jun 29, 2016 in FaderPort Classic by fabianoscarano (160 points)

Has just received my Faderport, but there was no installation CD in the box.Went to Presonus website and downloaded the FaderPort Installer - v135 - PC. For some reason it seems the faderport is not recognized, although I follow the exact instructions from the firmware updater. Can someone help?

5 Answers

+1 vote
answered Sep 11, 2016 by robertshepherd (170 points)
I'm waiting for an answer on this too.  I bought the Faderport and have had no success installing it -- Windows 10 simply cannot find it.  I've heard you have to uninstall (and sometimes physically disconnect) all MIDI devices,but that is idiotic and I am not going to disassemble my computer to install a USB controller.  I'm not thrilled that I bought a product that I cannot use -- can someone please advise when proper support for Windows 10 will be available?  Update 1.3.8 does NOTHING for me, and neither does 1.3.5.
+1 vote
answered Feb 8, 2017 by kocakastavarac (240 points)
Same problem here. Unit works on my laptop so it`s not faulty but i can not install it on my DAW. I installed a fresh OS on a clean disc so there are no drivers or anything left over and it still won`t install. And on my laptop i DO have drivers for USB sound card installed and it didn`t cause any problems. Yea the unit is cheap but it COST you a ton of time to get it to work obviously. That sucks....
0 votes
answered May 25, 2017 by andrefernandes1 (370 points)

Same here. I am super disappointed with PreSonus. They market it as compatible with Win 10 but I have tried everything to get it to work with Sonar and nothing, they don't even care to reply to my support ticket. Horrible experience, so far.

MY PC:
Windows 10 Pro | 64 bits | intel core i7-7700 CPU @ 3.60GHz | 16GB

1) I connected it my PC (regular USB with a MIDI keyboard also plugged) and it ran an automatic "install" so I was hoping it'd be plug and play. When I tried to connect it to Sonar, FADERPORT didn't appear in the Control Surfaces;

2) I read the manual but there was no CD so I created an account on your website and download the firmware update. When I ran it I got an error message: "Error: Could not find FaderPort control surface. Check the cables to ensure it is properly connected and press Next to try again";

3) I tried again, this time I disconnected all other MIDI devices and tried it on USB 2.0 and regular. Same error.

4) After this, I tried an older installer I found here:
http://answers.presonus.com/1644/why-am-having-trouble-getting-the-faderport-to-work-in-my-daw
It would run an installer (but not inserting the dll files) and then open again the recent firmware update that gives the error message.

5) As I couldn't get the installation done directly through plug or using your firmware and installer, I tried your manuall .dll install:
http://support.presonus.com/hc/en-us/articles/210040173

I copied the file to the right directory [C:\Program Files\Cakewalk\Shared Surfaces] but when I run the regsvr32 or C:\windows\SysWow64\regsvr32 register for FaderPort.dll I get the following error: "The Module FaderPort.dll failed to load. ...."


So, I don't know what else to try and I feel deceived.

–1 vote
answered May 28, 2017 by andrefernandes1 (370 points)
edited May 28, 2017 by andrefernandes1

I was able to install it in WIN 10/ Sonar Platinum, after a lot of struggle.

1) If you get an error when trying to manually register the DLL, just download this microsoft MS Runtime:
https://www.microsoft.com/en-us/download/details.aspx?id=21254

2) After registering it, check if your device name (in your DAW) is "FaderPort Update Mode". If so, it happens that when the firmware update results in the error, that turns the device into that Null entity, that doesn't work. You just have to uninstall FaderPort and remove all entities from the Device Manager ( in "Audio,Video,Game controllers"). Them restart Windows and it will re-install it "virgin", to work.

0 votes
answered Jun 17, 2017 by andypearce1 (140 points)
Try using a USB 2.0 port.

I had the same error message on my Macbook when trying to update the firmware to 1.3.8.  The updater does not seem to work with USB 3.0 ports.  I connected my Faderport to a USB 2.0 hub and this allowed the 1.3.8 update to go through.  After this update, the Fader port seems to work fine over USB 3.0.  

I know this is an old thread but I hope this helps someone in the future.
...