Questions & Answers

Anyone else experiencing issues with VST plugins when studio one updates

+2 votes
742 views
asked Aug 30, 2016 in Studio One 3 by dark7string (870 points)
It feel like since studio one 3.1 every time there is an update, something gets broken amidst the new features. This latest one (3.3) seems to have broken Melodyne, which I get that we need to back date to 3.2.3 to fix, but also it has broken Altiverb. When trying to load altiverb 6 (which has worked fine since Studio One 2) it completely crashes studio one. Keep in mind I have to use 32 bit to use altiverb 6 as it is 32 bit only but the issue has just started to occur since 3.3. There is now also an issue with the Klanghelm vu meters where it crashes if you try to double click and type in the number values. Also I am on Window 7 not 10 where most of the windows issue are occuring.

3 Answers

+1 vote
answered Aug 30, 2016 by rainerschulte1 (220 points)
Yes... me too!

In addition to the Update to Version 3.3 I added the VST-Plugin-Addon and MP3 Addon.

With the Setup, even with Win10 (but need to switch back to 8.1), I could load the Native Instruments Kontakt Player 5 with DrumMicA and another Synthesizer. But now I cannot access it anymore. I used it in my latest Song. Since it cannot be loaded again, the Sound is missing and the Instrument is claimed as missing Instrument.

The other Question is how to load Plugins with *.dll named Instruments. I have copied them into a folder called C:/VstPlugins and mapped it within Studio One in the VST-Plugin part of Setup. They are not listed in Instruments-Section of Studio One...

Who can help on this?

Best regards

Rainer
+1 vote
answered Aug 30, 2016 by pconlon (270 points)
There is another thread where I posted my problems with VSTs in 3.3 here:  http://answers.presonus.com/10005/third-party-instrument-libraries-longer-registering-studio

You are not alone :-).
+1 vote
answered Sep 12, 2016 by misterghost (160 points)
same thing happening with me and Drumagog

come on Presonus fix your 3.3 update !!
...