Questions & Answers

How to solve the Sustain Pedal issue!!

+4 votes
asked Nov 29, 2016 in Studio One 3 by Vyero (350 points)

In order to make the Sustain pedal work on your MIDI controller you have to do 2 things:

1.- Go to: Studio One > Preferences > External Devices
Double-Click on your MIDI device to make the Edit Device window appear. Uncheck every single box on the Filter Section. Close the Edit Device and the Preferences windows.

2.- Go to: View > MIDI Monitor
Uncheck all filters. Close the MIDI Monitor window.

Try your sustain pedal...      
                          ...You are welcome!

4 Answers

+1 vote
answered May 17, 2017 by Jamesrhone1 (179,410 points)
Best answer
Thank you for providing this solution.
+5 votes
answered Aug 7, 2017 by daveplumb (1,260 points)
Didn't work over here!
+1 vote
answered Sep 20, 2017 by calebcindano (160 points)
Thank you!! I'm new to S1, this solved my sustain pedal problem after much searching.
0 votes
answered Apr 5 by morganwallace (150 points)
My sustain pedal with my Midi was working fine yesterday, and now it's not registering the sustain pedal today. Had all of those boxes unchecked anyways, and followed these instructions to make sure, so not solving on my end!