Questions & Answers

Cascading issue - Slave inputs dont work

0 votes
asked Dec 10, 2016 in Ai Mixers by Hudsoncruze (160 points)
I have cascaded 2 RM32s and connected the CS18 as well. But the slave RM32 inputs (33 to 64) are not working.
I have updated all the firmware.
Individually,  both RM32s work absolutely fine. I have tried to switch the master and slave and yet they don't work. Although the slave rm32 responds when you hit on mute and switch on phantom.
Has anyone faced this? Please help!

3 Answers

0 votes
answered Dec 11, 2016 by wahlerstudios (105,310 points)

Try to establish a master/slave connection without CS18AI to check, if the RMs are really working. Check if the cards are sitting perfect (take them out, screw them in again), check the CAT5 cables. Cascading for the RMs is done through AVB, so you have an AVB switch running and you can use a router. So get an iPad involved or a computer connected via firewire to check if the RMs can be cascaded and do work. You really need UC Surface to have a deeper look into things! All firmware and software need to match, so also check UC Control/UC Surface.

Just one detail: Cascading two RMs takes about 8 seconds. You need to wait until this process is finished, otherwise there might be some things not working somewhere...

After you have examined the RMs, get the CSD involved. Try first to "add" the CS after cascading RMs was successful. It should accept the settings and be ready to work. If not, you should start to look at the IP addresses and in which mode your are connecting your machines.

It might also make sense to check if your CS works "single" with any of your RMs. If one combination (CS + 1 RM) does not work, this might also indicate where the problem could be.

0 votes
answered Dec 11, 2016 by Hudsoncruze (160 points)
I have tried every possible scenario.

I have changed the cables (CAT5 and even tried with CAT6) ... connected through MOTU AVB Switch.

Individually the CS18 connects to both RM32s  and works absolutely fine. Only when cascaded, the slave inputs aren't responding. Mutes + Phantoms work fine.

Tried it without the CS18 as well, same issue.
0 votes
answered Dec 11, 2016 by wahlerstudios (105,310 points)

Hmmm, it seems everything is absolutely perfect, but why doesn't it work? I don't have a CS18AI, so I can't check things, but I have two RM's and know how cascading works. I am using dynamic IP addresses. There is a video fro PreSonus (see link above), which shows how cascading works with CS and two RM's. Have a look if you find anything in the video that is NOT identical to your approach.

I would suggest two things. There is a guy in the forums, who works with RM32AI, RM16AI and CS18A. Ask your question in the StudioLive RM Series forum. Hopefully he has an answer for you. The second suggestion is to open a ticket in your account and ask PreSonus directly.

One last idea: All firmware and software versions are really matching?

UC 1.8 (Mac/PC) ­
RM Mixer Firmware ­ v9244
CS18 Firmware ­ v9203