Questions & Answers

Windows is unable to recognize my Audiobox USB

0 votes
asked Dec 27, 2016 in AudioBox USB by cotumb (170 points)
I recently got an Audiobox USB. Very excited to begin recording, I encountered a problem.  Whenever I plug in my device, an error pops up saying that Windows cannot recognize my device, saying that the device has malfunctioned.

I would believe that this is a software issue, but I have completely reset my computer and updated all of my windows files.  Along with the solutions offered to me by the Microsoft support live chat. No luck.

I was getting worried that the problem was with my Audiobox as when I plugged it into my Sisters laptop, I encountered the same error, but when I plugged it into my fathers laptop, the device worked perfectly.  I am just very confused.

Information that could be useful:

- Under my USB Controllers section in Device Manager, the Audiobox shows up as "Unknown USB Device (Configuration Descriptor Request Failed), when I view properties of this, the device status says "Windows has stopped this device because it has reported problems. (Code 43) A request for the USB configuration descriptor failed."

-I am updated to the latest version of Windows 10

-The computer is Running with an Intel i5 Processer, NVIDIA Graphics, 8 GB of RAM, and a 64-bit Operating System.

Please help me with this problem, I am almost out of options.

5 Answers

–4 votes
answered Dec 27, 2016 by themuzic (15,160 points)
Best answer
Please download the latest driver from Make sure you follow the on screen instructions very carefully. If you installed the driver off the disk you received with the Audiobox then it is old and this new driver should work.
0 votes
answered Dec 27, 2016 by mattcaprio (148,250 points)
Hi there.

I would recommend contacting technical support via a support ticket.

Just login to your account at , click on "Support", then "Create a support ticket", and follow the directions there.

It's very helpful if you have your hardware registered as well (but support can assist you with that if you're not sure how to do so).

They'll be happy to help you resolve this issue.
+1 vote
answered Apr 18, 2018 by johnwhite22 (630 points)
Try plugging it into the back of the computer, i.e. directly into the motherboard, rather than the front.

Sounds stupid and simple but worked first try.
0 votes
answered Jun 14, 2020 by davidzhang7 (150 points)
I'm having the exact same problem!

It worked on my Lenovo thinkpad E570 but it won't work on my ASUS VivBook 15
0 votes
answered Feb 28 by chris103 (140 points)
I'm having the same problem but the situation gets very wierd because my usb 96 unit worked like a charm for four years and now does not work on either computer and not only that but I boaght a second unit and having the same issue on both computers!!!!!!!!!!!!!!!!!!!!!!!!