Questions & Answers

Why is my audiobox usb driver installation failing?

0 votes
asked Mar 1, 2017 in AudioBox USB by paulm5 (150 points)
Hi all,

I have windows 7, and am unable to install the drivers for my audiobox usb. I downloaded the installer for the drivers (it only gave me one option--the windows version). I opened the installer and ran it for the Audiobox drivers (I don't need any of the other products--just the interface to work with Ableton), and strangely, Microsoft Visual C++ opened and ran a process (I have only ever seen visual C++ open up during this installation and subsequent re-installations). I never got any prompt to connect my device to the computer as articles on this website say I should have, and instead was prompted to reboot. I reboot, and nothing happens. If I then connect the device, windows opens a little bubble in the bottom right that says it's installing drivers, and then another bubble pops up to tell me this installation of drivers has failed. If I go into ableton and try to configure the audiobox with the ASIO drivers, it will tell me that the drivers were not installed properly. If someone could please tell me what's going on, I'd really appreciate it. Thanks

3 Answers

0 votes
answered Mar 2, 2017 by gadget69 (30,330 points)
selected Mar 13, 2017 by AlexTinsley
Best answer

First thing is, if this is an audiobox USB (original) it is a port specific device. This means it ONLY works on the port you installed it in. If you plugged it into ANY OTHER PORT after the installation on the original port, the device tried to install on THAT port also. You will likely need to uninstall and re-install the AB USB. There is a number of articles in the Knowledge base   (  ) about these issues and solutions.  (   )   I HIGHLY recommend you check these articles out.

Make sure you register all your Presonus gear in your "My Presonus" account, and make sure ALL your software and drivers are on the LATEST versions appropriate for your hardware and software. This is the SUREST way to insure a problem free experience. We continually vet the devices and software from the accounts to insure trouble free operation.

Make especially certain you have the latest versions of Universal Control for the AB USB and you FOLLOW the installation instructions! I know at one point you needed to install the software and WAIT for instructions to plug the AB USB in, if you had it plugged in when you installed the device it would fail on SOME systems.. remember, we are all using divergent systems with myriad configurations and this makes it difficult to solve the problems without knowing exactly what your system is. We have asked that you provide system specs in some situations to help us get a solution for you.

If NONE of these things help, create a tech service ticket so a tech can get you up and running. Also check out the the Knowledge base, and the user forums which are here to help!

Best regards
0 votes
answered Mar 13, 2017 by AlexTinsley (909,900 points)
Also make sure you have run all your Windows updates.

At a minimum you need this platform update for Windows 7 SP1.
0 votes
answered Apr 18, 2018 by johnwhite22 (630 points)
Try plugging it into the back of the computer, i.e. directly into the motherboard, rather than the front.

Sounds stupid and simple but worked first try.