Questions & Answers

Solved: I was maybe a bit to myopic

0 votes
asked Mar 13, 2017 in Ai Mixers by RochesterDude (220 points)

Got the UC software running, thanks for the help. I certainly knew that I needed the latest software on both the boards and software side. I went to the Firmware page and noticed a bunch of versions.  I blindly went to the link that was the lowest and rightmost on the page thinking the latest was at the bottom of the page.  I didn't check the version numbers of the various updates. Presonus could be a bit clearer on how they arrange things and possibly put a time stamp on them as to when they were made available. As you can see  (enclosed image) the version numbers have no sort order on them at all.

Also I tried to find somewhere in the UC documentation (like you had suggested) that would indicated which version of firmware I needed, couldn't find it. Anyway I took the latest version of firmware and that works great.  I also connected my board to my router and will now let the board decided if firmware needs to be updated.  Again, many thanks. 

related to an answer for: Additional information about problem

1 Answer

0 votes
answered Mar 13, 2017 by wahlerstudios (31,530 points)

I fully agree. The way firmware versions are presented, is totally confusing. But if you go to the download page of your product (, at least there is a chronological listing. Still you have to scroll down to "Universal Control" and read the release notes to figure out, what the latest firmware version is for the AI consoles AND you need to know that UC Surface 2.0 works without a firmware update... Digital life is not easy, but it's good that you got your machines running again! ;-)