Questions & Answers

Is there anyway to force firmware update on the Studio Mobile 192?

+2 votes
asked May 11, 2018 in Studio 192 USB 3.0 Interfaces by cstewart1 (400 points)
edited May 14, 2018 by cstewart1

I updated Universal Control Panel today and now my studio mobile 192 is Unresponsive. The light just stays red when hooked up. Doesn't even show up in the control panel anymore. It used to show up and say "DSP v(Invalid) / USB v0.00 / Bootloader v0.00" tried different usb cables and ports. Tried uninstalling and reinstalling drivers can't seem to get it to work now. Also tried to update firmware again but it just says "the attached hardware is already up to date. The ctrl+alt and clicking update doesn't work to force it to update again.

3 Answers

0 votes
answered May 14, 2018 by cstewart1 (400 points)

Although these instructions did not work for me. Maybe these instructions will help someone else. Tech support sent me them. I will most likely have to send my 192 in for repair. 

1. Power off the Studio 192.
2. Whilst holding down the '48V' and 'Cue' buttons, power on the Studio 192 (this will boot the Studio 192 into Load mode).
3. Open the Universal Control application and try to force the firmware update again.

Should this still not resolve the firmware issue, please try connecting the Studio 192 to your computer using a USB 2.0 cable and then repeat the above steps.

0 votes
answered May 20, 2018 by marekjele (190 points)
I have exact same issue with my Studio 192. Did You find any solution?
0 votes
answered May 21, 2018 by cstewart1 (400 points)

@marekjele  nope was told by support that I have to send it in for repair.