Questions & Answers

Windows 10 64bit, Firestudio Project, Universal Control Crashing at launch

0 votes
791 views
asked Oct 22, 2015 in FireStudio Series by blueskid (120 points)
edited Oct 22, 2015 by blueskid
Hi there, I just upgraded my computer to a brand new windows 10 64 bit machine. It's great. I installed a PCIe firewire card that has a chipset on the approved list. Now I run 3 firestudio project cards for 24 inputs. I've been able to get 1 card at a time to briefly work. But most times I try to launch UC with any of the sound cards connected I get this error that says UC wasn't installed correctly. Restart and or reinstall.. I've done that several times. I've removed all the associated files from %appdata% and reinstalled.. And UC just keeps on crashing. Any help would be much appreciated!

 

***Update

After some more troubleshooting.. I've found I can run any one of my 3 cards on it's own. I only get driver errors when I start to cascade the units. I've tried almost every possible combination with the 3 units as far as order goes and nothing works. As soon as I cascade It's crash city.

1 Answer

0 votes
answered Oct 22, 2015 by mwright137 (1,450 points)
The lowest serial number must be attached to the computer, then the next highest, then the highest in the chain. Make sure you're doing that first.
...