Questions & Answers

Midi not getting to VI in Studio One 3

0 votes
asked Sep 30, 2017 in Studio One 3 by brendantobin1 (200 points)
I have am running Studio One 3.5 on a 2011 3.4GHz i7 iMac, running 10.12.6.

I have instantiated Superior Drummer 3 on an instrument track and get sound from SD3 on the channel when mouse clicking the drums.

I have a Alesis e-drum kit hooked up and is set up in external devices receiving on all channels. I can see that midi is coming in as the midi monitor records the notes coming in and yet Superior drummer is not receiving any midi. I have record and input monitoring clicked, Input is set to all inputs and Output is set to Superior Drummer.

I am sure this has to be some small oversight on my part but I have been dealing for this for a few days now and I am frustrated enough to post this.


PS I LOVE Studio One and only want to work in this platform, but when performing this same task in Pro Tools I just open and run it in a matter of seconds with no issues.

3 Answers

0 votes
answered Sep 30, 2017 by karstenvogt (3,450 points)
Be sure to check the midi mapping. A midi note might arrive in your studio drummer 3 but if it's not mapped nothing will happen. And remember to check for velocity thresholds. Check this one:
0 votes
answered Sep 30, 2017 by brendantobin1 (200 points)

Thanks karstenvogt but...

Nope all mapping is solid. The module has been fully mapped to match the midi mapping inside Superior Drummer. As I said the same setup is working flawlessly in PT. 

Also when viewing the incoming midi in the midi monitor window in Studio One all the correct notes are coming in and showing up. So the correct midi and mapping is coming into Studio One it is just not getting to Superior Drummer.

NO midi is going to Superior Drummer. There is a midi mapping window and e-drum setting window in the new superior drummer and it just says "waiting for midi". Meanwhile I hit pads and the correct and corresponding midi notes show up in the Midi monitor window showing they are coming into Studio One properly.

See attached picture.

0 votes
answered Jan 23, 2018 by jasonvanvuren (140 points)

brendantobin1 were you able to resolve this? I am having the same issue as well.