Questions & Answers

Studio One 3 Memory Issue

0 votes
asked Dec 13, 2017 in Studio One 3 by gavinburns1 (120 points)
Hello! I would like to report an issue regarding my PC's memory and Studio One 3

I use a Toshiba laptop with Windows 10 and I have never had an issue regarding memory. I recently downloaded Studio One 3 and I've been having this very peculiar issue. Whenever I use Studio One 3, I can use it for about 15-30 minutes before my laptop gives me a memory warning and restarts. What's even worse is that the issue is permanent until I restart the laptop. I cannot exit Studio One 3 when I am given the warning, then boot it back up again, as my computer will crash if any other programs are opened.

I've taken some time trying to find resolutions to this problem. I don't think this is a problem with my PC, as the issue never occurred before I downloaded Studio One 3.

Any information regarding this topic would be greatly appreciated

3 Answers

0 votes
answered Dec 15, 2017 by andreasschwabe1 (1,250 points)
I've seen the same issue on my HP laptop. If I reboot, there's no issue. But once I use S1 in a session, I start getting "low memory" reports and errors. I'm following this thread too.
0 votes
answered Dec 17, 2017 by benchase1 (440 points)
I started encountering an issue today (on my tower PC, not a laptop) where all of a sudden a song I was working would no longer play. I tried closing Studio One, but it wouldn't shut down. When I opened Task Manager to shut it down, I could see that, although the song only had one short midi event and one short audio event, the memory usage kept shooting up (to over 8GB by the time I ended the task). When I restarted Studio One, everything was fine until I tried to load that song, at which point the memory usage started to shoot up again, though the song never opened. Again, after it hit 8GB or so, I ended the task in Task Manager.

The last thing I remember doing in the song prior to first encountering the issue was creating an automation lane for a parameter in the Kontakt instrument I was using (Orange Tree Sample's Evolution Songwriter). I don't know for sure, but I wonder if this is what triggered the issue. Does Studio One have a "safe mode" that would allow me to open the song without that instance of Kontakt?
0 votes
answered Dec 17, 2017 by benchase1 (440 points)
I disabled VST 2.4 Plug-In Support service, restarted S1, and was able to open the song.

I removed the automation lane, saved the song, enabled the service, restarted S1, and tried to open the song again. No joy.

I ended the task, restarted S1, disabled the service, restarted S1, opened the song, removed the Kontakt track and instrument, saved the song, enabled the service, restarted S1, and was able to load the song now that the Kontakt track and instrument weren't in it.

This is a bummer. Maybe the issue is specific to Evolution Songwriter, but I'm new to S1 and not being able to automate Kontakt parameters is a bit of a showstopper, given how much I use sampled instruments.

Sorry if I hijacked your thread, Gavin. Given that my issue was also a memory issue, I was trying to avoid duplication.

Anyway, with my issue, I don't know whether the fault with with S1, Kontakt, or Evolution Songwriter. I'll report it to all three developers and hope that one of them is able to sort it out.