Questions & Answers

All of the lights on my AudioBox iTwo are lit up and my PC isn't recognizing the device

+1 vote
asked Jan 10, 2018 in AudioBox USB by lonniebyrnside (210 points)
edited Jan 10, 2018 by lonniebyrnside
My Audiobox iTwo is not being recognized by my Windows 10 64 bit PC and all of the lights on the front panel are lit up, including two red ones.  I have attempted many of the solutions provided on the forums and on this site, including the installation of "Universal Control" (which doesn't recognize the device) and I also tried "AudioBox VSL v1.3" (I uninstalled UC before doing this, so the drivers wouldn't conflict and even tried the method of copying files from the 9 MB folder in my cache to the PreSonus folder, to no success and gave me an "error 5" message on the second go-around.)  Another forum user mentioned using a USB cable with the ferrite bead, but this also did not fix the problem for me.  Ultimately, the best solution, which would be updating/reinstalling the firmware on the device through UC, as suggested by someone on this very website, did not work since my PC didn't even recognize the iTwo.  My Audiobox's warranty has long since expired and I don't know what to do.  This issue in various forms has appeared on PreSonus forums many times over the years, so I hope someone has been able to work out a solution or remedy for this defect in the product.

Thanks and I hope you can help!

6 Answers

0 votes
answered Jan 12, 2018 by iriemorse (180 points)
im having the exact same problem and dont know what to do, i just got the device and it just wont connect.
0 votes
answered Jan 13, 2018 by josenegron2 (180 points)
I had same problem with mine had to go into settings and change from windows media player to the studio one midi for it to work. And I have windows 7 home office pro but for some reason the default settings from the computer wouldn't work with the midi , it was a pain in the *** to get to work but once you get it, it's great
0 votes
answered Jan 15, 2018 by iriemorse (180 points)

in response to  josenegron2's answer. IS there any way you could elaborate more on this solution. i dont quite understand your method and would like to see if it will work for me

0 votes
answered Jan 15, 2018 by lonniebyrnside (210 points)

I have opened a support ticket with PreSonus and am waiting to hear back from them. Could iriemorse try using the free Microsoft Windows USB Device Viewer, which I've uploaded the 32 bit (usbview86) and 64 bit (usbview64) versions to a Google Drive folder (see below) and see if your AudioBox appears in any of your USB ports? Mine does NOT, meaning that the AudioBox is receiving power from my computer, but it is not sending any data whatsoever to my computer. Usually, if a USB device was still working, but did not have a working driver on the computer, you would at least see "Unknown Device" or something indicating that the computer could at least recognize that there is a device connected to it. Anyway, could you see if your AudioBox shows up? If so, you're probably in a better situation than me, as it appears something is seriously wrong with my device (failed component(s) on the motherboard? corrupted firmware?). I'll keep you posted on my responses from PreSonus Support.

Download the .exe file and .config file corresponding to your processor/operating system type (32/86 or 64).

0 votes
answered Nov 28, 2018 by davinroche (150 points)
I had this same problem (all lights lit and guitar lights red), audiobox not picked up by iphon eor pc. The problem was my USB cable was too long, approx 3 metres. I replaced it with a 2 metre one, with one of those small cylinders at the end and problem solved.  I did install Universal Controller, but the problem only resolved after I changed cable.
0 votes
answered Jul 28, 2020 by jaywilson12 (180 points)
Try swapping the USB cable. I just encountered the very same thing when I plugged in a slightly longer, thinner USB cable that my normal one. There was also evidence that this faulty cable had been pulled out wrongly as the inner wires were exposed.

When I plugged in my normal cable it worked fine again.