Questions & Answers

Does Studio One Pro 4 support ilok plugins ?

+4 votes
2,163 views
asked May 24 in Studio One 4 by danielkaminski1 (400 points)
Does Studio One 4 support ilok plugins ? I upgraded 3.6 to 4 and i can use them in 3,6 but they don't appear in 4. I tried to reinstall Studio One and ilok, I also tried to rescan plugins. Nothing helps. I'm using 64 bit versions and win7 pro.

10 Answers

–5 votes
answered May 25 by AlexTinsley (733,660 points)
 
Best answer

Make sure the path to your iLok enabled plug in is added to your Plug-in Directory Paths. 

  • Open Studio One Preferences
  • Select Locations icon
  • Select VST Plug In Tab
  • Add your path there

+1 vote
answered May 26 by danielkaminski1 (400 points)
I have done locations before. And locations are exactly same as in Studio One 3. Thoose plugins are visible only with Studio One 3.
0 votes
answered May 28 by wes8 (630 points)
I am having the same problem as well. I've tried adding the plugin-locations and resetting the blacklist. Plug-in locations are the same between Studio One 3 and Studio One 4, but still not seeing the iLok plugins.
+3 votes
answered May 28 by wes8 (630 points)

Hey danielkaminski1, not sure if this will work for you, but I was able to get my iLok plug-ins to show up by doing the following:

1. Open Studio One 4

2. In the menu bar go to Help --> Open Settings Folder

3. Delete the Studio One 4 Settings Folder

4. Uninstall Studio One 4

5. Re-install Studio One 4

Then my plugins were scanned correctly. This was all after trying to reset blacklists and locations, so there still may be a Studio One 4 problem.

0 votes
answered May 29 by danielkaminski1 (400 points)
WORKS !
PROBLEM SOLVED. I did exactly as wes8 in 5 easy steps.
Thank You wes8 !
0 votes
answered Jun 7 by Curtsong (590 points)
I'm having the same issues.  Going to try this procedure.  I'll update with results.
0 votes
answered Jul 5 by minkyocho1 (430 points)
Solved, thank you very much Wes8!!!
+5 votes
answered Jul 14 by mornebester (240 points)

Some of my plugins got blacklisted, and after trying everything including 'Reset Blacklist' button, reinstalling plugins, restarting scanning S1-4 etc - I found the following solution to make them appear again.


NOTE:  Below is the answer of wes8 if you want to reinstall S1 - My solution is if you are comfortable with quickly editing a file in a text editor:
----------------------------------------------------------------------------------------------------

  • Open Studio One 4
  • In the menu bar go to Help --> Open Settings Folder
  • Look inside the "x64" folder for the Plugins-en.settings file [MAKE A COPY just in case]
  • Open the Plugins-en.settings file in any text editor
  • CLOSE S1 app
  • In your editor search for your plugin for example "Tube Delay"

You might now find an entry for VST2 and/or VST3 depending what you installed:

<Section path="B6B24A14/Tube Delay.dll">  AND/OR  <Section path="0CE10D5D/Tube Delay.vst3">
Directly underneath one of these lines you will find this:
<Attributes numClasses="0">
  CHANGE TO  <Attributes numClasses="1">

IF you now go "FInd next" in your editor you might also find pathes - you can ignore them:
<Url type="1" url="file:///C:/Program Files/Vstplugins/Softube/Tube Delay.dll"/>
<Url type="1" url="file:///C:/Program Files/Common Files/VST3/Tube Delay.vst3"/>

REPEAT for all your plugins.

SAVE the file
----------------------------------------------------------------------------------------------------
If you now open S1 your plugins should all show.
I think after a blacklist these plugins stay hidden and the 'Reset Blacklist' fails to make the changes to make them appear again.

0 votes
answered Aug 11 by jefflogan (150 points)

THANK you  mornebester . By far the easiest and fastest fix! Awesome. Thanks again. 

0 votes
answered Nov 21 by russelldusseault (180 points)

 mornebester - I am so grateful for your answer. This worked like a charm, and saved me so much work and aggravation. 

(my plugins got blacklisted by forgetting to use ilok and moving licenses to the PC before installing Studio One 4 Pro)

...