Questions & Answers

Will my existing Waves plugins integrate automatically and work with my new Studio One 4 install

+4 votes
asked May 28, 2018 in Studio One 4 by earledaniels (760 points)
I currently have several Waves plugins running on Studio One 3.5. I will install Studio One 4 on the same Windows 10, 64-bit PC and was wondering if my existing 3rd party Waves plugins will be automatically integrated into Studio One 4 after installation.

17 Answers

0 votes
answered May 29, 2018 by fransvannispen (5,730 points)
Yes, all plugins will also be available in S4, and you can (at least on OSX) install Studio One 4 side by side with Studio One 3, so you can still open the session in S3 as well (as long as you did not save it again from within S4)
0 votes
answered May 29, 2018 by williamgagnon (1,640 points)
Im gonna say no, None of my Waves plugins work with S14.   Only half are listed and the ones there don't work.   I talked with Waves and they say Studio One 4 is not yet compatible.   What a freaking nightmare.    Funny thing, they seemed to work okay until I bought a new plugin this morning.   That's when the trouble began, the new plugin didn't show up and all the other Waves plugins stopped working as well.    Tried uninstalling everything, still they don't work.   I hope they can fix this.   I am dead in the water without those.   So, Fransvannlspen, try loading in a new plugin and see what happens.
0 votes
answered May 29, 2018 by williamgagnon (1,640 points)
I just checked the list sent to me from Waves, Studio One 4 is not yet compatible. I have no idea when they will be.  Would have been a nice thing to know before the upgrade.
+2 votes
answered May 29, 2018 by earledaniels (760 points)
This is not what I wanted to here. I would not have upgraded to Studio One 4 had I known that Waves plugins wont work on this platform. Is this a Waves or a Presonus compatibility issue?
0 votes
answered May 29, 2018 by williamgagnon (1,640 points)
I don't know Earl.   I'm guessing its a Waves thing.   I'm not sure how they work together on compatibility issues but I hope they fix it soon.   If they work on yours,  don't add anything new from Waves until they confirm compatibility.   that's when I ran into trouble.  I could try and remove both S13.5 and S14, then just install S14.   That would be the last thing ill try.   But Waves did tell me that S14 is not yet listed.
0 votes
answered May 29, 2018 by williamgagnon (1,640 points)
From what I am seeing, it works good on Apple but not on PC's.   So if you have an Apple it might be fine.   Of course I use PC's so I'm sol at the moment.
+2 votes
answered May 30, 2018 by objectsatrest (310 points)
edited May 30, 2018 by objectsatrest
I upgraded from 3 to 4 and all my Waves plugins (and all the other plugins I have) show up and are working in version 4. However, I just bought a new Waves plugin tonight and it will not show up in version 4. I still have version 3 on the same machine so I checked there and the new plugin shows up as expected. I put in a ticket to Presonus about it.

UPDATE: On a whim, I found the location of the Waves plugin folder and added that location ( C/Program Files (x86)//Waves/Plug-ins V9 ) in the VST locations options in version 4. Did a scan and now the new plugin is showing up in version 4. My version 3 doesn't have that specific location for Waves and it added the plugin just fine in version 3. I then added the new plugin to a song and its working. Feels like a workaround and not a fix, but it got the new plugin to show up.
0 votes
answered May 31, 2018 by williamgagnon (1,640 points)
Read objectsatrest's answer,  it works perfectly now.    My guess is they make all the new products work for apple, then they do windows.  Seems to be a simple miss but no big deal for us Windows users.    Just add the location to the plugin scan area and they all show up and work perfectly.    That's why ive used and built pc's forever, you can fix things like this.  Even a bonehead like me:)
0 votes
answered May 31, 2018 by earledaniels (760 points)

Hi William, thats good new about your Waves plugins now working in S14. When you say "Just add the location to the plugin scan area and they all show up and work perfectly", where is this scan area in S14? Can the location be quite general, eg: C:/Program files. I ask this because I have plugins files located in several folder locations under Program files.

0 votes
answered Jun 11, 2018 by jimfoster1 (270 points)

I've attempted the workaround by objectsatrest below. I'm dead in the water.

Started with Waves 9, Studio 1 v4. Everything worked except some newly purchased plugins.

Upgraded Waves platform and plugins to v10. Now NOTHING from Waves loads into S1v4.

Attempted workarounds shown here. No joy. 

Opened S1v3. Waves 10 plugins load fine. We need a fix to this ASAP. S1v4 is worthless to me without the FX stacks I've built for my various jobs. 

0 votes
answered Jun 11, 2018 by earledaniels (760 points)
edited Jun 12, 2018 by earledaniels
Hi Jim, I have loaded all my Waves V9 plugins into S14 and they seem to be working OK. I was going to upgrade all my Waves plugins to V10 but after your latest news I am not so sure. It is interesting that the latest compatibility note from Waves states that V10 plugins are still only compatible with Studio One 3.5 (and not S14). I will upgrade my Waves plugins to V10 and let you know how I get on.

I also updated all my Waves plugins from V9 to V10. The updated Waves plugins loaded successfully into S1v3 but failed to load into S1v4. I have the same problem as you. Not sure if this is an S1v4 problem or a Waves V10 problem as I had all my Waves V9 products loaded and working fine in S1v3 and S1v4
0 votes
answered Jun 12, 2018 by adamredgewell (970 points)
I'm also on Windows 10 64. My Waves V9 plugins worked fine in both S1 v3 and S1 v4, despite S1 v4 not being listed as supported on the Waves site. However, I made the mistake of upgrading the plugins to v10 yesterday and now none will load in S1 v4. I'm currently in the process of downgrading to V9 again and keeping fingers crossed that the old plugins reinstall correctly...

Interestingly the V10 plugins loaded correctly in Sonar Platinum so I think this is an S1 v4 issue.
+1 vote
answered Jun 13, 2018 by earledaniels (760 points)

I have some good news for all those S14/Waves V10 plugin users. I have fixed the problem. Here are the details :)


Waves V10 .dll files are placed in the following location by default;

C:\Program Files (x86)\Waves\WaveShells V10

Studio One 4 is a 64-bit system, so I think it is ignoring any content located in C:\Program Files (x86). Because of this, the Waves V10 .dll files are not found by Studio One 4 on start-up and therefore the plugins are not loaded into the DAW session.


  • Create a sub-folder called "Waves" located under C:\Program Files\Vstplugins.
  • Copy all content from C:\Program Files (x86)\Waves\WaveShells V10 and paste into into new "Waves" sub-folder.
  • Start-up Studio One 4 and add a new VST Plugin path called C:\Program Files\Vstplugins\Waves. This function is
    accessed under Studio One>Options>Locations>VST Plug-Ins. Hit "Apply" then "OK".
  • Close down Studio One 4 and re-open it. You will now have a "Waves" plugin folder in your Browser containing all the
    Waves V10 plugins.
0 votes
answered Jun 17, 2018 by earledaniels (760 points)
I have been corresponding with Waves support team and as a result, they have been doing some testing and created the following paper found at this we link;
0 votes
answered Jun 19, 2018 by benmcclure1 (410 points)
edited Jun 19, 2018 by benmcclure1
The link from Waves about how to find your plugins doesn't help in my case.

Even after adding the mentioned locations, and seeing that my Waves V10 plugins do exist in the place I'd expect, Studio One scans them (I can see the Waves plugin names pop up briefly while it's scanning), but none of them actually show up in Studio One after that. S1 V4 sees all of the Waves V10 plugin files just fine, it just doesn't seem to work with them.

I've also tried the other recommended fix, copying the Waves plugins to C:\Program Files instead of C:\Program Files (x86) and then pointing S1 there instead, but it did not make a difference.
0 votes
answered Jun 24, 2018 by earledaniels (760 points)

If all your Waves plugins appear in S14 but when you add a new plugin it doesnt appear in your Browser, add the following pathway to Locations, VSTplugins, C\Program Files (x86)/Waves. Hit Apply & OK, then restart S14. Your new plugin should now appear in the Browser plugin list.

0 votes
answered Jul 4, 2018 by benmcclure1 (410 points)
I finally figured out a solution for me:

Browse to %AppData%, and rename the folder Presonus\Studio One 4\x64 to something else (like x64_old), then start Studio One v4 again and set up your plugin paths from scratch. It scanned, then indicated it would be updating my Waves shell plugin next time I restarted Studio One 4. So I restarted it, and now I can see my Waves plugins showing up in Studio One again finally!

Solution came from here: