Questions & Answers

SOLVED: Waves Plugin Folder Will NOT Show in Studio One 4 Pro (Win 10, i9 processor)

+1 vote
1,302 views
asked Jul 12 in Studio One 4 by pauldecesare (3,350 points)
edited Jul 13 by pauldecesare

UPDATE, 7/13: I used Waves Central to reinstall all my waves plugins (Repair option on one of the menus). Then I deactivated and uninstalled Studio One 4. Lastly, I renamed the C:\[username]\AppData\Roaming\PreSonus\Studio One 4 folder to something else, to cause Studio One to rebuild that during the reinstall.

Next was a clean install of Studio One 4. That fixed it, the Waves folder now shows up and the plugins work. This solution assumes a proper installation of Waves of course.

I noticed in the newly installed Studio One that there was only ONE location entered for Plugin location: C:\Program Files\VSTPlugins. Makes sense, that's where the Waves DLL is and studio One 4 is all 64 bit for plugins now, so we don;t need any references to Program Files (x86), at least for Waves v10 plugins.

END

=================================

Original rant (now a moot point):

Been using Studio One and Waves for 4 years, never an issue. This is a new PC I've built with new installs of Win 10 Pro (and all updates), Studio One 4 Pro and Waves Plugins, ALL of which are upgraded to v10.

I've been through the PreSonus checklists several times, doing the blacklist reset, scan at startup, deleted and re-entered the 4 file paths to VSTPlugins in Program Files and Program Files (x86), they won't show. I then deleted Waves entirely and reinstalled, but they still won't show up on the effects list. I get PreSonus and NI [plugins, plus EastWest Spaces and they all show up and work, but Waves will not appear. I just did the Studio One 4 update from two days ago, thought that would do it.

I'm now concerned it's processor support, but before I open a ticket I was hoping to hear from anyone else. I upgraded to the i9-7940X which is Xeon-Based and discovered that Notion 6 will not run, Notion does not support the processor. PreSonus knows about it and right now is saying "Sorry, and we have no word on when that will be fixed." That was literally the email from Tech Support. So now I wonder if this is the issue with Waves.

Anyone else running an i9, and does it work for you?

2 Answers

+1 vote
answered Jul 12 by brianmeisner1 (181,860 points)

The best answer to this is to contact Waves and have them assist you in installing the latest build and verify that all of the .dlls are installed to the correct location.  They can also help you with verifying your plug-in paths for Studio One.  There have been some issues recently with Waves and they should be able to get you sorted.  If you upgraded from 9 to 10, you may want to take a look at the following article on the Waves web site.

https://www.waves.com/support/plugins-do-not-load-after-v10-update

Below you will find some general troubleshooting steps for plug-ins not showing up in Studio One.

***Studio One 4 has a window that appears when scanning plugins that allows you to skip or disable plug-ins. Please take a look at the following article from the PreSonus Knowledge Base for information on managing plug-ins.

https://support.presonus.com/hc/en-us/articles/360004055292-What-is-the-difference-between-skip-and-disable-in-the-new-plug-in-scan-and-how-do-I-manage-my-plug-ins-now-

If you are missing plug-ins in Studio One, and you have read the above article, please take a look at the following information.

Windows:

  1. Please open Studio One and go to Studio One>Options>Locations>VST Plugins and verify that you have the correct directory added to the list of folders that the program scans at startup. You want to add the directory that you have your plug-ins installed to. If you do not see the "VST Plug-ins" tab under the Locations tab, then you want to make sure that you have activated Studio One Professional or Producer or you have installed the VST, AU, and ReWire support add-on if you are running the "Artist" version of Studio One. Press the "Reset Blacklist" button while you are in this window.

  2. Right-click Studio One and choose "Run as administrator" when opening the program to determine if there is a possible permissions problem.

  3. Studio One 4 will only load 64-bit plug-ins, as it is a 64-bit app. If you loaded your VSTs from the c:\Program Files (x86) folder into Studio One under the "Locations" tab, this is more than likely your 32-bit plug-ins. Your 64-bit plug-ins should be installed under the c:\Program Files directory, without the (x86) next to it.

  4. Please click the icon of the wrench in the browser window, at the top, right-hand corner of the window, to open the plug-in manager. Make sure that there is a white dot next to the plug-in, if it shows up in the list.

  5. If you are still having a problem, try contacting the manufacturer of the plug-in for information about updates, compatibility issues with Studio One, or possible workarounds.

***For information on using a memory bridge to load 32-bit plug-ins into a 64-bit host, please refer to the following article:

https://support.presonus.com/hc/en-us/articles/360003940771-Is-there-a-32-bit-version-of-Studio-One-4-How-do-I-load-my-32-bit-plug-ins-


For general troubleshooting of Studio One, you can try removing your settings files from the program and re-configure.  Here are instructions:

  1. Go to Help>Open Settings folder.

  2. Copy the contents of the folder over to a folder on your desktop.

  3. Close S1 and delete the contents of the settings folder with the exception of the user.license file as well as the "Extensions" folder.

  4. Open S1 and go to Studio One>Options (Preferences on a Mac) to reconfigure your settings.

  5. Test to see if the problem is resolved. If it is not, please feel free to copy your settings files back over from the backup that you created in step 2.

*If you are missing presets or Sound Sets after doing this, simply double-click one of your Sound Sets under Documents>Studio One>Sound Sets.

0 votes
answered Sep 27 by kozmyk (870 points)
selected Sep 27 by pauldecesare
 
Best answer
I had to do that Blacklist Reset malarky just the other day to get some Waves plugins to show. Added a couple of new paths and they were sorted.
THEN
Today, I got a few more Waves thanks to the Anniversary Sale.
Rummaged through my Wish list  etc etc..
Would today's t̶o̶y̶s̶  serious productivity tools, show up in S1-4 ??
Would they f&*^$&*(&^ ...
Round and round I went, repeating all the steps I'd used a few days ago . Nothing ... n..u..th..i..n..g
After some frustration and bad language, I tried S1-3.5 just in case And THERE they were !!!
But not in 4
Comparing the paths I saw one that S1-4 didn't have.
Put that one in and Whammo, all fixed.
So now I have FIVE plugin location paths .

I don't know if S1-4 is using them ALL but I'm not going to play Sherlock Holmes trying to eliminate any unused paths.
If it ain't broke etc ...
...