Questions & Answers

Still got problem with "limited or no connectivity" issue.

+3 votes
226 views
asked Jun 27 in AudioBox USB by jakubkotynia (190 points)
Hi!

I have an AudioBox iTwo device. I did everything as it has been written but the problem still exist.

Any other suggestions?

1 Answer

0 votes
answered Jul 1 by joakimmller (150 points)
edited Jul 1 by joakimmller
SOLVED!

(for me at least)

I had the same issue despite trying the Presonus website solutions.

Using newest UC version 2.7.0.47644, Win 10 laptop, UC finds the Audiobox iTwo but when I double-click it in the UC window nothing happens for a few seconds then the small windows appears saying that there is no or limited connectivity to the Audiobox.

Since the Audiobox iTwo only handles up to USB 2.0, I tried using USB 2.0 all the way. I used an older laptop with only USB 2.0-ports, a USB 2.0-cable running from the laptop to the Audiobox iTwo and everything worked. The Audibox iTwo showed up in UC and I finally managed to update my Audiobox iTwo to the latest firmware, 1.33.

EDIT: just for testing purposes I afterwards tried a USB 3.0-cable and it worked as well so the issue seems to the USB-ports of the computer hosting the UC app.

Regards,

Joakim
...