Questions & Answers

new Studio 1810 not working or showing up in Studio One audio device list

+1 vote
103 views
asked Aug 12, 2018 in AudioBox USB by billschletzer (190 points)
I spent eight hours downloading software today after my 1810 arrived in the mail.  Next downloaded universal control, the version that was listed for 1810.  In studio One there are about eight devices showing but none are the 1810.  When I turn on the 1810 the normal display flashes briefly, then turns off.  After that the four lighted switches flicker dimly.  I tried downloading universal control again but got the same list of devices, no 1810.  I don't see any answers in the user manual or online.  I assume I'll wait a week for a meaningless reply to this question like, "did you plug it in?" or something useless like that.

5 Answers

0 votes
answered Nov 28, 2018 by svanangen (140 points)
Sorry, no help from me but I would like to report the same issue here. I get the "limited connectivity" from UC and it doesn't show up in Studio One (v. 4 prof.).
0 votes
answered Dec 7, 2018 by antalackak (150 points)
Same issue, there is no 1810 driver in the newest version of Universal Control. I checked all of the files in the download and no driver for the 1810 but as you stated there is drivers for all of their other equipment.
0 votes
answered Dec 29, 2018 by kaspernikolajandersen (160 points)
Same issue here. Anyone got a fix for this or is it a hardware problem???

Kasper Nikolaj
0 votes
answered Dec 29, 2018 by billschletzer (190 points)
I looked back at my emails to see what my solution was.  The problem was that the computer didn't recognize the device when I plugged it in, hence it didn't show up in the list.  With the help of Sweetwater technical support we determined that the Presonus 1810 was defective.  I exchanged with Sweetwater and the new device showed up in the listed and connected correctly.  Hardware problem.
0 votes
answered Jan 11 by waynewhite1 (140 points)
Mu 1810 came today & I have the same issue. Was looking to see if there is a resolution.  The 1810 doesn't show up.  I tried downloading a couple and I got several models now showing up in my device list, but only 1 of them 'kinda' works. In a video I watched, it shows 2 selections for Audio devices. Input & Output. Mine only has Output.  On my Input Source (Windows Control Panel) there are choices fo Inputs 1&2 or 3&4, etc, but no choice for a Unit.  I tried a Focusrite unit & it had the Unit as a Source for Sound & Mic.  I ma hoping with the correct driver, this 1810 will work the same way.  My input seems to be OK, but my output is only good for Mics 1 & 2. 3&4 are very soft.  I have 1&2 selected for the Mic (for lack of a good choice)...Wayne
...