Questions & Answers

My Faderport Classic has stopped working: macOS Mojave , Logic Pro X 10.4,2

0 votes
838 views
asked Oct 5, 2018 in FaderPort Classic by leroy749 (290 points)
It was working. The only change was updating my OS to Mojave and Logic from 10.4.1 to 10,4.2

4 Answers

+1 vote
answered Oct 11, 2018 by florianerlbeck (460 points)
selected Jun 12 by nickmaggio
 
Best answer
Try This:

download the fader port control update from June 2018. works fine here with Mojave and Logic 10.4.2
+1 vote
answered Oct 7, 2018 by anass1 (160 points)
I have the same problem. After both updates my Faderport classic stopped working. The firmware update didn’t help. Logic doesn’t recognize the faderport as controller. But it is still available as midi device.

My configuration: iMac 21’’, latest generation, OS Mojave, 8 GB RAM, Logic Pro x 10.4.2
0 votes
answered Oct 7, 2018 by johnelleson-hartley (150 points)
I'm still on Sierra 10.12.6 and, after updating to Logic 10.4.2 from 10.4.1 my Faderport stopped working (same as when I updated to 10.4.1). Followed same approach as before (which had worked perfectly) by following this https://support.presonus.com/hc/en-us/articles/210040223 and installing the Faderport Classic. Was then prompted to update my firmware from v.1 to v.1.45 - followed the instructions but got a "Universal Control. The firmware update failed with error code 0x80004005.

After a few tries, and restarts, the Faderport still wouldn't show up. I gave up and installed it as a Mackie HUI and thankfully it is now working for me. I only use the main features so this is fine for now and at least I keep working :) Hopefully Presonus will sort this with a proper update, though as it's a legacy piece of kit? That shouldn't make any difference ;)

Know that doesn't answer the Mojave part but at least it's working for me in Logic. Good luck!
...