Questions & Answers

Faderport Classic has stopped working . update: how it was fixed

0 votes
1,159 views
asked Aug 17, 2018 in FaderPort Classic by rboyle (280 points)
edited Sep 3, 2018 by rboyle
My faderport classic was working but has stopped. I didn't change anything. I have Studio One Pro v 2.6 and Win 10/ 64 Creation Station Computer

I tried updating the software but that also doesn't work I get the same error message everyone is complaining about? I have a USB 2 connection.

I would like to purchase Studio One Pro version 3 but I am reluctant to do so because I need a fix for this first. Also  my hyperlinks in the Studio One news feed no longers connects me to your webpage.  Thank You

Update: Thanks for the answer. I did get my faderport classic going again. I have Win10 x64 , Studio One Pro 2.6  I went and downloaded the faderport 1.45 update again. I have a 2.0 usb connection. I then updated the software into my faderport . It updated to 1.45 but still didn't work.   I tried unplugging the usb and the power and connecting them  and rebooting a few times. Finally in Studio One external devices I looked and it said not connected and changed it to "fire port to fireport" and then it worked.

1 Answer

0 votes
answered Aug 31, 2018 by butchrichard (131,070 points)
 
Best answer
Reset the FaderPort.  Disconnect the USB and the power cable.  Wait a minute.  Reconnect.  It should work as usual.

The firmware 1.45 is only to fix an issue with ProTools.  If you are using Studio One, you do not need to update.

If you want to update, ensure you are in fact connecting to a native USB 2.0 connection.  

Know that you can use the FaderPort classic on a USB 3.0 connection, you just can't update it on them.

You can try connecting the FaderPort to another computer with USB 2.0 and attempt to update there as well.

You should also contact PreSonus Support for further assistance.
...