Questions & Answers

Why won't my Alesis DM10 MKii play in Studio One 4?

0 votes
330 views
asked Nov 3, 2018 in Studio One 4 by charlesrouse (480 points)
It works in Mixcraft 8 Pro. Stands to reason it would work it Studio One 4. It doesn't. The in-program manual is too basic and I can't find any videos on the topic. Really not enjoying this!

4 Answers

0 votes
answered Nov 3, 2018 by charlesrouse (480 points)
I am going from the Alesis Module to the PC via USB
0 votes
answered Nov 4, 2018 by kevinrendleman (1,380 points)
Make sure you go into preferences and device setup.  The DM10 isn't in the library of presonus presets, but no biggie.  Just create a new generic midi keyboard, and be sure to call it DM10.  Click the send to and receive from tabs, and select the USB DM10 i/o from those dropdowns.  If all goes well, you should be able to set the DM10 as your input on a new intrument track.
0 votes
answered Nov 4, 2018 by charlesrouse (480 points)

I just did what kevinrendleman suggested. Had not tried it before, but still no luck. Here is how it is configured. Should I try to play the drums  with something other than EZDRUMMER2? What is there in Studio One 4 for providing drum sounds. This all seems a bit complicated to me. But, I still have 3 weeks to decide whether or not to use it.

0 votes
answered Nov 4, 2018 by charlesrouse (480 points)

Well, color me confused! Suddenly, it works. I didn't make any other changes since I set it up as a keyboard. I went back and deleted THAT, and set it up as an instrument, and it is still working! 

As a side note...the sound was double triggering in  EZDRUMMER2. Switching it to EZDRUMMER fixed that right up. Any thoughts on this craziness? 

...