Questions & Answers

When I play my Midi instrument I hear two instruments at one time

+2 votes
3,149 views
asked Dec 12, 2018 in Studio One 4 by marcusruhdorfer (140 points)
Hey, guys! I have a really strange problem now and I've still found no solution in the Forum, maybe you could help me.
I created recently one song and started with the drums from the impact instrument. I record everything with my AKAI MPK mini at the moment.
One day later I opened the song file and wanted to add some of the analog labs synths. But for a strange reason my keys are now sort of double layered. I play any synth sound, no matter which I choose, and hear in addition to the synth sound the drum sounds from the impact as well.
The monitor buttons (the blue speaker knobs in each track) are off in any track except the one I want to record!
Now I made some experiments:

I recorded something in the song file: in the recording you don't hear the drum sound the midi board regenerates while playing.

I opened the edit mode - no additional sounds in the key bar there.

I deleted all other tracks. This doesn't change anything

I opened another file I had - in this file everything is alright

I opened another song file I had - no problems there.
So what could it be? could someone help me or did anyone have a similar problem?
I haven't found a solution in the manual either.

Thanks for response, mates!

4 Answers

0 votes
answered Dec 12, 2018 by moriromio (140 points)
You checked your Midi Input channels in the instrument window? Probably the same input channel.
0 votes
answered Nov 12, 2020 by ivoryjacksoniii (240 points)
I have the same problem I've been trying to figure out..I have an akai mpk mini3 and trying to figure out why when i play it, as i have two tracks ...one with Impact because i want to use the snare..and one with Mai Tai, on either track i hear the sounds from both virtual instruments...can't figure it out...on the akai mpk i have all midi channels selected(should I?)..thought it might be because they're both coming thru on the same channel..idk?..but having trouble finding where to find what channels they're coming thru on??....
+1 vote
answered Feb 14, 2021 by margaretboyce1 (160 points)

I just figured out how to fix this (was having the same issue--so frustrating!). It's really easy. When you open the Instrument panel to record your track using the MPK mini (i.e. the pop-up screen with the keyboard and all the drop-down menus for instrument options), first click the tab at the top for any other instruments that you've already recorded. Then just click the power icon on the top left, to turn off that instrument. Easy peasy. See my unforgiveably hideous screen shot w/ "circle" for reference. Screen shot of Instruments panel 

0 votes
answered Jul 6, 2022 by antg1 (720 points)
Perhaps a better solution is to simply go back to the tracks you no longer need to REC on and change the INPUT to "none"

Turning the Power Button to "off" on the VST actually disables it. This is an issue during playing thus if you have Impact on Tracks 1 and 2.

You can't hear Playback on Track 1 for a reference.
...