Questions & Answers

Studio One 4 crashes upon loading

+2 votes
2,768 views
asked Jan 3, 2019 in Studio One 4 by hartleywynberg (180 points)
I use Focusrite Scarlett 18i8 2nd Gen audio interface. I can use Studio One 4 audio editor when I first boot up Win7, but if I use any other audio like VLC or iTunes then load up Studio One 4, it freezes the whole system and I must hard reboot the computer.

I've updated everything I could, software, drivers and Windows, no success.  I have UNCHECKED "allow applications to take exclusive control of this device" (https://www.sweetwater.com/sweetcare/articles/how-to-install-focusrite-usb-drivers-on-windows/).

3 Answers

0 votes
answered Jan 6, 2019 by dboucher (230 points)
Sorry I don't have an "answer" but it happens quite frequently to mine as well (2012 imac Quad core/20 GB ram) so I don't think a performance issue has any relation. I've sent tickets/screen shots/crash logs to no avail.... it seems to happen more since the latest "bug fix". In my case when it does "hang" I found if you just leave it be (for around 5 min in my case) it straitens itself out. As for myself, I'm not far from dumping Studio one for a real "Professional" daw... yes, I'm talking about Pro Tools. So good luck, and back-up (very often)  :)
0 votes
answered Jan 6, 2019 by hartleywynberg (180 points)
Thanks for responding dboucher.

Solution, I think?

Presonus / Configure Audio Device / Audio Setup / Audio Device - select Focusrite, Device Block Size 512
Control Panel / Sound / Playback tab /
- Set As Default
- right-click Focusrite USB / Properties / Advanced tab / Exclusive Mode, uncheck Allow applications to take exclusive control of this device
Control Panel / Sound / Recording tab /
- Set As Default
- right-click Focusrite USB / Properties / Advanced tab / Exclusive Mode, uncheck Allow applications to take exclusive control of this device
Here's what I think cleared things up - Start / ASIO Control Panel / set samples to 512, not 8 ?!?  (I kept seeing ASIO bubble in the task bar when I loaded up Studio One, and I finally clued in that ASIO was my motherboard's sound, not the Focusrite, I think).

I followed the Sweetwater advice on optimizing the PC for audio with Win7, including "#7. Disable USB Selective Suspend (for USB interfaces). This prevents your hub driver from suspending an individual USB port. To do this: Start - Hardware and Sound - Power Options - Change advanced power settings - USB Selective Suspend and select 'Disabled'"

So far so good.  Loads up fine no matter what other audio software I'm playing.
0 votes
answered Jan 5 by Jas001 (190 points)
I have the same problem using Studio 24C in windows 10.  I've tried switching to windows audio, and when loading the project you can hear midi lock happening.  This version is definitely not working as reliably as 3 for me.
...