Questions & Answers

Notion 6 has just made a hash out of a MIDI file -- anything I can do about this?

+1 vote
asked Jan 30, 2019 in Notion by cooltouch (440 points)
My machine is running Win7 64-bit with 16 GB of RAM. Performance isn't an issue here. I own a copy of Notion v.4, which if I'm to be perfectly honest, I don't care all that much for. So before I even think about shelling out the bucks for Notion v6, I thought I'd give the demo a go. Which is what I've just done. I have just now installed the Notion 6.5 demo and installed the bundled instrument files. Once this was completed, I imported a MIDI file of one of my own compositions from Cakewalk Sonar (actually Cakewalk by Bandlab now, but basically the same thing). I configured the file as MIDI 1. Then imported it into Notion 6. Instantly I could see that it had made a complete hash out of the file. Not only was the notation not correct -- it wasn't even close. And the playback was totally inaccurate. So, not willing to try and edit this mess, I went back to Cakewalk and configured the file as a MIDI 0 file. Not expecting much, I imported it into Notion and was surprised that this translation was at least slightly more accurate -- in terms of notation, at least. But even the MIDI 0 file was nowhere close to being accurate, either in its display or its playback.

The only reason why I even tried exporting this file from Cakewalk, where it plays perfectly, by the way, was because Cakewalk's notation "feature" caps its resolution at 32nd notes, and I have a few phrases where 64th notes are used. So when these occur, they appear as being doubled up on the staff. That is, two notes sharing the same stem. This piece was initially composed using a notation-based sequencer product that has been defunct now for a number of years -- Midisoft Studio -- which could handle 64th notes. It wasn't good for much of anything besides scoring out music, however. So all the tweaking was done in Cakewalk. Cakewalk has always handled the translation of MIDI files from this old product just fine. Even though Cakewalk couldn't accurately display the notation -- 64th notes, in this instance -- the playback was correct.

One of my goals is to be able to render an accurate printout of this piece of music. The way things stand with Notion 6 right now, this won't be accomplished without a mountain of editing. I've also tried MuseScore 2, Crescendo Music Notation Editor, and Noteworthy Composer 2. All of them made a similar mess out of this file, each doing it in its own curious way -- no two ways being exact.

I guess I'm wondering why this should even happen, given that a MIDI file is primarily providing time, pitch, and volume values for specific instrument patches. It doesn't seem to me that there should even be any variability at all in the way a file should appear -- or sound. But there is.

So I guess I'm wondering, is there anything I can do with Notion -- or prior to importing the file into notion perhaps? -- that will help me to render a more accurate file after its import?

1 Answer

–1 vote
answered Jan 31, 2019 by cooltouch (440 points)

Well, I found a solution to my problem. It's called MuseScore 3. While v2 didn't behave, v3 did and it imported and translated the file perfectly, even properly displaying the 64th notes. It has a decent mixer, where voices can be selected easily, and where other elements can easily be assigned. Editing is straight forward enough too. So I'm happy and it looks like I won't be buying a copy of Notion v6 after all. Why should I, when MuseScore 3 does all I need and is free to boot?