Questions & Answers

Just Installed Studio One 3 on EL Captain, Why Is it crashing while vst/plugins are are being scanned?

+1 vote
500 views
asked Dec 30, 2015 in Studio One 3 by camo (140 points)
Never Once has it loaded also I upgraded from SO2 Pro To SO3 pro

2 Answers

–1 vote
answered Dec 30, 2015 by AlexTinsley (762,350 points)
As of Studio One 2.6.4 and now with 3.0

StudioOne installs by default in 64 bit mode on MAC OSX.

There is an option with in the software Application folder under the Get Info/General tab to run as 32 bit mode.

The following knowledge base article explains this in a bit more detail.
--> http://support.presonus.com/entries/58052740-Studio-One-2-6-4-Mac-OS-X-64-Bit-with-32-Bit-Plugin-Compatibility-
0 votes
answered Feb 16, 2016 by Mick Cunningham (860 points)
I had the same problem: Tech Support gave me this response and it worked. The funny thing is that once every plugin had been moved and then copied back in, S1 didn't crash. So I never found a problem plugin, but the process must have fixed something so now its ok.

Here's the solution that worked:...

Please go to Macintosh HD\Library\Audio\Plug-ins\VST, VST3, and Components.

Copy the contents of these folders to respective folders on your desktop so that the original folders are empty.

Open S1 and test for the issue again. Add your plug-ins back to the respective folders a few at a time until you can identify the one that is causing the crash. You will then want to contact the manufacturer of the plug-in for information about compatibility, updates, and known issues.
...