Questions & Answers

Faderport 2018 will not work AT ALL on my Mac running High Sierra... but I was told it would! How do I get this to work?

0 votes
asked May 6, 2019 in FaderPort 2018 by thaddeusaustin (240 points)
I recently purchased a faderport 2018 after being assured the thing would work on my Mac.  I run Reaper.

It doesn't work at all. I can't tell if the thing is in MCU mode or not. Reaper 'sees' the device but it does absolutely nothing.

How can I at least get the start/stop transport and volume fader to work? Please?

4 Answers

0 votes
answered Jun 12, 2019 by nickmaggio (26,640 points)
Best answer

Support for the Faderport in Reaper is handled by Reaper in their Forums.. 

however you can follow these instructions to test: 

(ensure you are in MCU mode) 

  1. Open Reaper
  2. Click the "Options" drop down menu and select "Preferences
  3. Click on "Control Surfaces" within the Preferences menu
  4. Click "Add"
  5. Select "Mackie Control Universal" as Control Surface mode
  6. Select "PreSonus FP8" as your MIDI input and MIDI output

0 votes
answered May 8, 2019 by thaddeusaustin (240 points)
Just to put some meat on this...

-- I have updated the firmware o the Faderport.

-- I tried installing the Faderport XT driver, as discussed on other forums. No diference.

-- I have tried both modes, and it's definitely in MCU mode now.

-- I have tried different USB ports. No diference. The software 'sees' the device, the device just can't control anything.
–1 vote
answered May 11, 2019 by edramsey (2,160 points)

Wow. Sorry to hear about the problem.

I love my FaderPort 2018; its almost the whole reason I moved from Logic to S1 last year :-).

Have you tried the info at this link?             Faderport V2 (2018) and Reaper *SOLVED*           

Good luck!


0 votes
answered May 11, 2019 by thaddeusaustin (240 points)
That link doesn't pertain Ed. That link is for Windows workarounds, not a Mac one. Thanks though.