Questions & Answers

Anyone having issues with latest FW update for RM32AI?

+1 vote
76 views
asked May 24 in Ai Mixers by paulalvarez (250 points)
I raised a ticket and Presonus support was unable to provide a solution so I was curious if others have had this issue:

Tried doing the usual firmware update (latest on file) using a properly formatted thumb drive and when initiating this via UC Surface I get an error message that the RM32AI is not registered even though it is.  I was asked to wait for another update but wanted to see if any others had experienced this.

2 Answers

0 votes
answered May 26 by wahlerstudios (50,350 points)
I have no idea how this registration thing can be solved, but I know that the latest firmware is NOT A GOOD THING for the RM/RML mixers. The beta version was released as final version, with all the bugs in it. It neither brought improvements, nor added new features. The firmware update was only good and needed for the CS18AI. The combination of "old" (RM32AI) and "new" (CS18AI) works perfect. The Firewire Display Lag was anyway not solved. And do not count for any futher update, because the RM mixers are legacy products.

Try to get the former firmware back to your RM. Maybe this also solves your registration problem.
commented May 28 by benpierce (90,410 points)
Actually, the product manager for the live sound mixers has publicly said recently that another Ai series release is currently being worked on. There isn't a release date as of yet, but it is coming. As far as the registration issue goes, contact Sales or Tech Support and have your serial number handy. They can help ensure that your mixer is registered properly.
0 votes
answered Jun 5 by obpsoundfolks (400 points)
As far as my own recent testing has shown, the problem with the registration not showing correctly has to do with the server that holds that information and how it is not connecting properly via the internet, i.e. you can't perform a firmware update directly on the mixer, nor from UC connected to your mixer. This appears to be a bug in their system and shouldn't affect your actual registration that was done on their website.
...