Questions & Answers

ATOM Velocity Function Not Working

0 votes
asked Oct 2, 2019 in Atom Pad Controllers by carsonsherlock (240 points)

Everything on ATOM works great except for the velocity adjustment pads in the Editor mode on the controller.

(Editor) + (Velocity -)  or (Editor) + (Velocity +) do not work.

Just to be clear I am not talking about the input velocity curve.

I can still edit the velocity with my mouse and I can even manually assign velocity increase and decrease functions to 2 of the pads in the Song Setup mode on the ATOM.

I am using the most recent update of Studio One  4. The firmware on the ATOM is 3.0. I have checked countless forums and watched several "how to videos" on the ATOM. After searching everywhere on the internet, it appears that I am the only one having this problem. I have also uninstalled and reinstalled Universal Control a few times.

When pressing the pads, Studio One is receiving the midi commands, but the velocity does not increase or decrease (and yes the note that i want to modify the velocity of is selected).

This is probably less of an ATOM issue and more of a setting issue in Studio One. I have run out of things to try so hopefully there is someone out there that can connect the dots for me.


5 Answers

+2 votes
answered Dec 13, 2019 by zpoztric (520 points)
selected Dec 25, 2019 by carsonsherlock
Best answer
This can happen if you optionally change the user data location.
The cause is a lack of macro files.
The macro file that is automatically generated in the user data location does not contain the macro file that ATOM uses.

ATOM velocity editing is done via macros.
And the modified user data location is missing some macro files.
It contains macro files that ATOM uses for velocity editing.

Copy the following macro file from "C: \ Users \ [UserName] \ Documents \ Studio One \ Macros" to "Macros" in the user data location.

Deselect All.studioonemacro
Leg + Ovlp.studioonemacro
Quant 1_16.studioonemacro
Quant 1_4.studioonemacro
Quant 1_8.studioonemacro
Rmv Gaps.studioonemacro
Select Notes Menu.studioonemacro
Track Zoom L.studioonemacro
Track Zoom M.studioonemacro
Track Zoom S.studioonemacro
Vel + 10.studioonemacro ← Use ATOM
Vel-10.studioonemacro ← Use ATOM
Vel max.studioonemacro

In addition, edit the default "Vel + 10.studioonemacro" as follows.

<? xml version = "1.0" encoding = "UTF-8"?>
<Macro title = "Vel +10" group = "Musical" description = "">
<CommandElement category = "Musical Functions" name = "Velocity">
<CommandArgument name = "Mode" value = "0" />
<CommandArgument name = "AddValue" value = "0.078740157186985015869140625" />
<CommandArgument name = "SetValue" value = "0.791666686534881591796875" />
<CommandArgument name = "MultiplyValue" value = "1" />
</ CommandElement>
</ Macro>

This is because the default "AddValue" value is incorrect and the velocity increase is unstable.

I hope you find it useful.
0 votes
answered Nov 10, 2019 by martinbrataas (330 points)
You are not the only one. I posted a similar thread. Still no solution

0 votes
answered Dec 25, 2019 by carsonsherlock (240 points)
Great Job zpoztric!

I was missing a few of these macros completely.

Even when I did a clean install of both windows 10 and Studio One.

None the less, great work. This solved the issue precisely.

Thank you!
0 votes
answered Jan 29, 2020 by alexandrlukyanov (140 points)
The same problem, but I still do not work with pressure. I do not have another Macros folder in the laptop. Where to get the missing macros files?
0 votes
answered Feb 2, 2020 by carsonsherlock (240 points)


Follow this link

Then scroll down to the bottom of the forum and look for a comment by zpoztric

The Macro Zip folder is available there for download.