Questions & Answers

Issues in recording with Capture with a SLIII/16R connected to a MacBook Pro

0 votes
asked Nov 7, 2019 in StudioLive Series III by frasermoffatt (280 points)
Hi - I just picked up a StudioLive 16R to replace an ailing SL16.4.2 that I was using with an older 2011 MacBook Pro and an iMac for live and recording.  16R seemed like a good upgrade to what I was moving from and for my more recent needs (smaller footprint, portability, etc).

I tested out the SLIII/16R on my iMac (running Big Sierra) and it works exactly as I expected it would with no ******** around. Signal comes through UC and is passed to Capture for recording. Toggle the playback in Capture with the digital send button. All systems go. Works fine with Logic Pro X. Set up and ran like expected right out of the box. Good to go.  My old MBP more or less died and is limping along with Ubuntu Studio - but that's another story!

I also upgraded to a more recent MBP - the one with the top USB-C ports and got the SLIII/16R up and running but no joy with recording in Capture.  Did not run as expected right out of the box as it did with my iMac.

I've installed the latest versions of 16R firmware, UC (3.0.2.***) and Capture 3 (3.1.1.***) and I'm running Mojave 10.14.5 on the new MBP.  All systems go with UC. No go with Capture. Also installed the latest public beta of the 16R firmware to see if that was an issue.  No difference. Everything works as expected in UC but I get no signal passed to Capture and nothing is recorded when I attempt to do so.  I've played around with the software based input and output settings and nothing doing. Rebooted computer, rebooted 16R. No difference. Should be working right out of the box like it did with my iMac but that's not the case

Anyone else experience this problem with Capture and find a work-around? Why would it be specific to my MBP and not my iMac? Would it be HW/SW compatibility with the version of MacOS running on MBP vs. iMac?  Only other variation is having to the use Apple USB-C adapter with the iMac - but why would that affect Capture and not UC?

The Capture User Manual is pretty sparse in the troubleshooting department and offers no suggestions. Didn't see anything relevant in the UC user manual either.

Also, seems like Capture is a bit buggy in that the Digital Return button appears and disappears at times on both the iMac and MacBook implementations.

One other thing I noticed is that the SLIII/16R defaults to a 44.1kHz sample rate when connected to the iMac but defaults to 48kHz when connected to the MBP.

The 16R hardware seems awesome and I like the Presonus UC workflow.  I would hate to have to return this unit due to unstable/incompatible software and my MBP...or having to consider buying a Win10 system!

7 Answers

0 votes
answered Nov 8, 2019 by wahlerstudios (104,410 points)
UC Control is not passing any audio. It's simply a control instance. Therefore it is quite possible that even if you see something happening in UC Surface, Capture is not receiving any audio signal via USB 2. You should check if Capture "sees" the 16R as audio device and to which sampling rate the rack mixer is set to by default, because Capture takes THAT setting. You should also "options" in Capture (see start page).
0 votes
answered Nov 8, 2019 by frasermoffatt (280 points)
@wahlerstudios - thanks for your reply.  I think you're on to something around how Capture sees the 16R wrt to sample rate.  On my iMac, the SLIII/16R comes up with 44.1kHz as a default in both UC and Capture. Interestingly, 48kHz isn't available as an option in this environment.

On the MBP,   the SLIII/16R comes up with 44.1kHz by default in UC and 44.1kHz in Capture by default. There is no option to select 44.1k in Capture upon launch (or even afterwards).   I *can* change the sample rate setting in UC to 44.1kHz in UC after I launch the software and enter the setting screen. I cannot do the same for stays at 48.0kHz with no way to change to 44.1kHz.

So then I changed both UC and Capture to 48.0kHz to see if that helped. No - same result. UC behaves. No signal going to Capture.

In the Mac Audio Devices control, SLIII/16R appears as both input and output devices, and the sample rate follows whatever I set in UC. Whatever, I do Capture does not seem to follow.

So, I'm left to conclude that, for some reason, Capture "sees" the hardware, but it not responsive to it, UC or audio settings on the iMac. I'm suspecting a driver problem somewhere along the line that's specific to this particular MBP and its OS.  

This is disappointing since I bought this hardware (and the new MBP) in part to support multi-channel live capture of band performances in a seamless manner, having used similar approaches with my now largely obsolete SL16.4.2.

Sure, there's other software solutions aside from Capture, but having to fire up something that is not necessarily integrated into the SL architecture defeats the purpose. What's especially frustrating is that the 16R works entirely as expected on my iMac. I'm at the point where I want to return this and go with similarly spec'd Mackie or ********* hardware.

One last question for @wahlerstudios:  Are you sure that no audio is passed from UC to Capture? First, it seems that channel gain in Capture is controlled within UC's channel strip. Second, it seems that I can send a post-fader signal from UC that then prints my EQ, FX, dynamics to the recorded signal in Capture (well, on my iMac setup, anyways).
0 votes
answered Nov 8, 2019 by frasermoffatt (280 points)
Another quick follow-up.

I uninstalled and reinstalled the correct version of Capture for the MBP - just to eliminate that as a variable.

A key change I see is that Capture does now come up at 44.1kHz by default and is consistent with UC.

However, Capture is still not getting a signal from the 16R.

0 votes
answered Nov 8, 2019 by wahlerstudios (104,410 points)
Thanks for the update. I was going to add this, but you were first... ;-) Hopefully this can help.

Definitely, UC Control/Surface is only control, no audio. Audio is USB and therefore computer... Pre/post is a setting for recording, allowing you to record signals with or without processing. It's not Mac specific.

The 44.1/48 kHz question is "decided" by the mixer, not the computer or Capture/DAW. You open UC Control, see the mixer, launch UC Surface, then you go to Settings and under Audio there are all options available. The rack mixers offer 44.1 and 48 kHz as Sample Rate (44.1 was added in April 2018) and if you don't see the two options, there is something wrong with your computer, not the mixer!

Any settings made under Options are kept from the rack mixer, but they should be stored in a project/scene. When you launch Capture, you will see your mixer, the name of it (with a option to select anther interface) and 48 kHz as FIXED sample rate, because the rack mixer is set to 48 kHz.

I am repeating this because this procedure shows immediately if something is wrong somewhere. When the settings of the mixer (UC Control/UC Surface) are how you want them to be, Capture WILL start with exactly these settings. If it doesn't, something is wrong in the computer, which will also affect any other mixer you connect.

Here are two helpful articles from "Techniocal Articles", dealing with connectors and cables. You need to have the right cables and adaptors.

It might be the best to open a ticket and get some help from Support.
0 votes
answered Nov 8, 2019 by wahlerstudios (104,410 points)
If a ticket is not an option and you're on Facebook, there are two private groups with a lot of Mac users. Check them out...!

Presonus StudioLive Series III Users

PreSonus StudioLive Series III DAW Mode
0 votes
answered Nov 8, 2019 by frasermoffatt (280 points)
Thanks again @wahlerstudios!

Going for my last option before submitting a ticket....just in the process of updating the OS to Catalina from Mojave. Not sure that'll make a difference but we'll see.

Thanks for the forum and facebook group links. I will check them out.

Crossing fingers!
0 votes
answered Nov 8, 2019 by frasermoffatt (280 points)
Well, one last update on this issue for now.

1. Updated macOS on the MacBook Pro to Catalina. Still the same problem with's not recording anything.

2. Uninstalled Capture 3 and installed a version of Capture 2 (circa Mountain Lion).

Wow, got a good result: Capture 2 records the audio no problem. It's missing the tighter integration with UC that Capture 3 offers but at least I know what the problem is now...buggy Capture 3 software for macOS (Mojave and Catalina, at least).

3. Submitted a support ticket to Presonus for this issue. Support is closed until Monday, so I don't expect any kind of result for a few days. But at least I can use this system as intended for the time being.