Questions & Answers

I’m unable to connect my new Presonus Quantum Audio Interface with my new PC

+1 vote
313 views
asked Jan 13 in Thunderbolt - Quantum by kevinscott5 (130 points)

So the Quantum runs but with the Red ‘On’ button indicating it’s not connected to the pc

The PC is working fine and is perfectly happy running my other interface a first gen Focusrite 18i20 interface via USB.

The pc cannot ‘see’ the Quantum.

The Quantum is physically connected via an Apple Thunderbolt cable, a Startech Thunderbolt  adaptor and an Asus ThunderboltEX 3 Card.

I installed the Thunderbolt drivers that came with the Asus PCI card and the Thunderbolt card appears in the system tray – when interrogated it reports ‘Attached device chain’ = blank.

All cables appear to be fitted correctly..

Any help gratefully received, many thanks Kevin

SCAN 3XS TZ390 - Computer Music PC

Mother board - Asus PRIME Z390-A,
Intel Core i9 9900K s1151,
2x8GB Cors VENG LPX DDR4-2666

ThunderboltEX 3 Card PCI Exp,
Apple MD861ZM/A Thunder Cable,
Startech Thunderbolt 3 to TB, TBT3TBTADAP

1 Answer

0 votes
answered Jan 26 by pylot (150 points)
Hi, I got the same issue but with a Asrock X570 Creator and a Startech Thunderbolt adaptor.

It worked for a month, just when entering powersave i had to restart.

But now nothing helps. I disconnected and reconnected all cables and restarted >10 times, updated drivers but the red light is on and it won't turn blue and nothing is listed in the thunderbolt software.
...