Questions & Answers

My Quantum interface will not properly connect to my MacBook Pro. Blue thunderbolt light flashing infinitely.

+1 vote
783 views
asked Jun 6, 2018 in Thunderbolt - Quantum by mattstevens4 (200 points)
I recently factory reset my Mac.  As of yesterday, you'd plug in the thunderbolt connector and it would work perfectly fine.  Today, it won't stop flashing.  I tried multiple versions of Universal Control, I tried enabling/disabling Gatekeeper on my Mac, and I'm simply stuck...

Has this happened to anyone else?  Where is the issue here?

3 Answers

0 votes
answered Jun 8, 2018 by mattstevens4 (200 points)
selected Jun 25, 2018 by benpierce
 
Best answer
Update:  although I had the newest drivers and firmware installed, the problem turned out to be within the thunderbolt ports themselves on my MacBook. A factory reset corrected the issue.
0 votes
answered Jun 8, 2018 by somosound (160 points)
Can you confirm you are using the most current UC and that drivers are all installed. It sounds that if you did a fresh install something wasn't reinstalled.
0 votes
answered May 2 by mikemiller30 (140 points)
I know this is a 2018 article, but it's 2020, but for those of you who are looking for help, here it is. I just got my Quantum 2626 today, and was having the same problem. I resolved the problem by uninstalling the UC, and reinstalling it.

Then when I opened up the UC, it took a while to find the 2626. Once it found it, it showed it needed a firmware update. I updated the firmware, and once updated,

I followed the instructions and shut off the 2626 and disconnected the Thunderbolt cable for 10 seconds. I then reconnected and turned it on. Blue light was continuous. I then shut off the UC app and got back into it. It again took a while to find the 2626, but found it. I got back into Logic Pro X and found the drivers. Works beautifully.

My takeaway: It takes a while for the Universal Control Surface to find your new hardware, and then you will need to update it. It will take a while to find it again, but will connect and you will be all set. At least that's how it worked for me. I hope this helps.
...